Curriki
  1. Curriki
  2. CURRIKI-5816

Links of the user names broken in search result view

    Details

    • Type: Bug Bug
    • Status: Verified Verified
    • Priority: Critical Critical
    • Resolution: Fixed
    • Affects Version/s: 1.11 New Core 3.5
    • Fix Version/s: 1.11 New Core 3.5
    • Component/s: Search
    • Labels:
      None
    • Similar issues:
      CURRIKI-3928beta& dev> Groups>Home tab >Group Contributions >Enter resource name and click Search. User taken to curriculum tab. But no result shown.
      CURRIKI-6323Broken link in Embed View
      CURRIKI-156Dead links in collections- Some user's have bad resource links, which appear in search results.
      CURRIKI-5403Selecting User Name in Search Results brings up Page Not Found
      CURRIKI-2880Advanced serach>Resouce tab's Setting not getting saved when user views a group and come back to advanced search.
      CURRIKI-5922Broken Users in Database - Email Not Showing
      CURRIKI-3006Search > Members > The search result is not giving proper results.
      CURRIKI-2287When a User view another user's profile, "'Change My Photo' link is displayed if there is no image for that user.
      CURRIKI-3781Search: Browse Group Numbers not Matching Search Results
      CURRIKI-1959remove hyperlink from ICT terms and icons in search results

      Description

      If you do a search and viewing the result list, the user names should be links to the corresponding user profile pages. These links are broken and you get "page not found" after clicking on them.

        Activity

        Todd Sherman added a comment -

        I logged in as TestingTodd222 and the number of contributions is zero. The bug is in search results.

        Paul Libbrecht added a comment -

        The link was output empty because the JSON was missing the contributor property. That was caused by incorrect field-names in the CurrikiExtJSONResponseWriter (which dictates which field is loaded in order to present the response, it was contributor and should have been creatorCode) and by the schema indicating it was not stored.

        Funnily, this was not showing on my dev platform. I think the difference is that of scale: the field was loaded anyways since memory is not critical on my dev server but not on current where the world is a lot more crowded.

        After re-indexing, on current, it is now complete.

        paul


          People

          • Assignee:
            Todd Sherman
            Reporter:
            Felix
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:
              Date of First Response: