Uploaded image for project: 'XWiki Platform'
  1. XWiki Platform
  2. XWIKI-14392

Failed apt-get upgrade from 6.1 to 6.2 due to manually changed /etc/xwiki/xwiki.cfg file

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Cannot Reproduce
    • Affects Version/s: 6.2
    • Fix Version/s: None
    • Component/s: Distribution - Debian
    • Labels:
      None
    • Environment:
      Ubuntu 12.04.5 LTS server, 64-bit Linux 3.2.0-67-generic kernel.
    • Similar issues:

      Description

      On XWiki instance which is installed as a .deb package (see: http://platform.xwiki.org/xwiki/bin/view/AdminGuide/InstallationViaAPT ) I got upgrading errors because of changed content of /etc/xwiki/xwiki.cfg file. Actual lines I have changed were:

      xwiki.cfg:xwiki.authentication.validationKey=...
      xwiki.cfg:xwiki.authentication.encryptionKey=...
      

      which I did because of security reasons.
      I could only solve this by purging all xwiki-enterprise-tomcat7-mysql and containing packages and by forced reinstalling them.
      Because of this many packages uses *.local configuration files which are ignored by package manager, but are used by application to override default values. Probably this should be introduced also for XWiki.

        Attachments

          Activity

            People

            • Assignee:
              tmortagne Thomas Mortagne
              Reporter:
              valdisvi Valdis Vitolins
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:
                Date of First Response: