XWiki MS Office Integration
  1. XWiki MS Office Integration
  2. XOFFICE-199

Changes to font and font size in Word don't show up in the browser

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Critical Critical
    • Resolution: Fixed
    • Affects Version/s: 1.1 M1
    • Fix Version/s: 1.1.1, 1.2 M1
    • Component/s: XWord
    • Labels:
      None
    • Environment:
      Windows Vista, Microsoft Word 2007
    • Similar issues:
      XOFFICE-193Changes made in the size of a table's cells using MS Word don't appear in the browser
      XOFFICE-197Increasing indent in word does not show in browser
      XOFFICE-183Box in Word is table in Browser
      XOFFICE-203Justifed Text in Word isn't justified in the browser
      XOFFICE-205Centered image in browser appears left aligned in Word
      XOFFICE-180A hyperlink to an image in word appears next to the image in the browser
      XOFFICE-182Shapes inserted in Word get displayed in a table in the Browser
      XOFFICE-181Coloured text in Word is black when you see it in the browser
      XOFFICE-184When an url label is the url itself, editing it in word causes for the webpage address to be changed
      XOFFICE-100Speed up Word startup time

      Description

      Steps to follow to reproduce:

      • Create a page and save it
      • Write some text in word
      • Select the text and change the font size
      • Click "Publish Document"
      • Open the page in the browser

      Result: The text is in normal size, not the new size that was specified in Word.

        Activity

        Florin Ciubotaru added a comment -

        This seems to be a XE issues. The css stored in the ssx object don't seem to applied every time.
        XOffice saves the page multiple times when publishing a document. I'll try to switch to a single save process to avoid inconsistencies.

        Florin Ciubotaru added a comment -

        Hmm, actually it's not that easy to reduce the number of saves since this a limitation of our current XML-RPC api(when pushing data, one call = one save).


          People

          • Assignee:
            Florin Ciubotaru
            Reporter:
            Silvia Rusu
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:
              Date of First Response: