XWiki MS Office Integration
  1. XWiki MS Office Integration
  2. XOFFICE-204

"Wiki Explorer" button still highlighted in the ribbon after the wiki explorer has been closed

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 1.1 M1
    • Fix Version/s: 1.1 M2
    • Component/s: XWord
    • Labels:
      None
    • Environment:
      Windows Vista, Microsoft Word 2007
    • Similar issues:

      Description

      Steps to follow to reproduce:

      • Click on the "Wiki Explorer"
      • Close the "Wiki Explorer" by clicking X or down arrow+Close

      Result: the "Wiki Explorer" button is still highlighted in the ribbon

        Activity

        Florin Ciubotaru added a comment -

        OK, I need to sync the toggle behavior with the state of the wiki explorer. It's a bit more tricky in a multiple document scenario because there's only one ribbon(displayed several times) and a separate pane for every Word instance.
        What do you think it should happen when closing one of the wiki explorers?
        1) Closing a wiki explorer means closing the wiki explorer on all Word windows -> The button has the state for all the panes
        2) Closing a wiki explorer does not affect other similar panes -> The button only has the state of the wiki explorer corresponding to the active window. When switching to another Word window the button takes the state of the pane for the new Word window.

        Silvia Rusu added a comment -

        +1 for 2)

        Alexandre FABRY added a comment -

        I have the same problem but beacuse of the fact that the "Wiki explorer" is still highlighted, it doesn't function.
        I'm using Windows XP, Microsoft Word 2007 and XWord 1.2.
        Can you help me?


          People

          • Assignee:
            Florin Ciubotaru
            Reporter:
            Silvia Rusu
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:
              Date of First Response: