Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.18
    • Fix Version/s: 1.26
    • Component/s: Skin
    • Labels:
      None
    • Similar issues:
      XSTOUCAN-81Radeox Code Macro doesn't use a monospace font for highlighted keywords
      XSTOUCAN-72The styles used by box and code macros are restricted to xwikimaincontainerinner
      XSTOUCAN-96##{{{test}}}## fails to be displayed correctly
      XSTOUCAN-99Fix style when code macro is used inline
      XSTOUCAN-59Code macro style is broken
      XSTOUCAN-61The class "macro" for div element does not print the box
      XSTOUCAN-123Headings font size improvements
      XSTOUCAN-68Remove from 'code' css class the box drawing related things and adjust the 'box' class
      XSTOUCAN-4#displayPanelLayout macro doesn't display correctly the columns
      XSTOUCAN-76Nicer look for the RSS macro 2.0

      Activity

      Vincent Massol added a comment -

      See screenshot.

      Input was:

      {{code}}
      iiiiiiiiii
      mmmmmmmmmm
      {{/code}}
      
      {{code}}
      public class MyClass {
        public void helloWorld() {}
      }
      {{/code}}
      
      {{code language="xml"}}
      <hello>
        <world>Cool!</world>
      </hello>
      {{/code}}
      
      Vincent Massol made changes -
      Field Original Value New Value
      Attachment Picture 2.png [ 14804 ]
      Vincent Massol made changes -
      Fix Version/s 1.8.3 [ 11067 ]
      Fix Version/s 1.9 M2 [ 11040 ]
      Thomas Mortagne added a comment -

      This is a regression in Toucan I think since it did use a monospace before...

      Thomas Mortagne made changes -
      Project XWiki Core [ 10010 ] XWiki Toucan Skin [ 10305 ]
      Key XWIKI-3613 XSTOUCAN-80
      Affects Version/s 1.18 [ 11030 ]
      Affects Version/s 1.8.1 [ 11009 ]
      Affects Version/s 1.9 M1 [ 11010 ]
      Component/s Skin [ 10772 ]
      Component/s Rendering 2.0 [ 10725 ]
      Fix Version/s 1.8.3 [ 11067 ]
      Fix Version/s 1.19 [ 11055 ]
      Fix Version/s 1.9 M2 [ 11040 ]
      Vincent Massol added a comment -

      Thomas, this is different from XSTOUCAN-81 since the new code macro doesn't use the same CSS for keywords to highlight.

      Thomas Mortagne added a comment -

      I read too quickly and just seen "Radeox Code Macro doesn't use a monospace font"

      Thomas Mortagne made changes -
      Fix Version/s 1.20 [ 11095 ]
      Fix Version/s 1.19 [ 11055 ]
      Jean-Vincent Drean made changes -
      Fix Version/s 1.21 [ 11113 ]
      Fix Version/s 1.20 [ 11095 ]
      Jean-Vincent Drean made changes -
      Fix Version/s 1.22 [ 11130 ]
      Fix Version/s 1.21 [ 11113 ]
      Jean-Vincent Drean made changes -
      Fix Version/s 1.23 [ 11146 ]
      Fix Version/s 1.22 [ 11130 ]
      Thomas Mortagne made changes -
      Fix Version/s 1.24 [ 11168 ]
      Fix Version/s 1.23 [ 11146 ]
      Thomas Mortagne made changes -
      Fix Version/s 1.25 [ 11187 ]
      Fix Version/s 1.24 [ 11168 ]
      Thomas Mortagne made changes -
      Fix Version/s 1.26 [ 11201 ]
      Fix Version/s 1.25 [ 11187 ]
      Vincent Massol added a comment -

      The pb is that the toucan CSS sets sans-serif as the font for <span> elements even if they are inside a <div class="box code">

      Vincent Massol added a comment -
      sdumitriu
      19/Aug/09 16:37
      View full commit
      XSTOUCAN-80: Code Macro should use a monospace font Fixed. git-svn-id: https://svn.xwiki.org/svnroot/xwiki/platform/skins/trunk@22786 f329d543-caf0-0310-9063-dda96c69346f
      Sergiu Dumitriu added a comment -

      Fixed in rev. 22786

      Sergiu Dumitriu made changes -
      Status Open [ 1 ] Closed [ 6 ]
      Assignee Sergiu Dumitriu [ sdumitriu ]
      Resolution Fixed [ 1 ]

        People

        • Assignee:
          Sergiu Dumitriu
          Reporter:
          Vincent Massol
        • Votes:
          0 Vote for this issue
          Watchers:
          0 Start watching this issue

          Dates

          • Created:
            Updated:
            Resolved:
            Date of First Response: