Details

    • keywords:
      history,store,DBimprovement,soc
    • Similar issues:
      XWIKI-3653Edit comment and Minor edit settings lost when going to the preview and back to edit
      XWIKI-2207The Document API does not allow saving a minor edit
      XWIKI-2681Minor edit checkbox and default language field doesn't work
      XWIKI-8002Allow 'minor edit' to be set by default
      XWIKI-8773Documents are saved as minor versions when clicking the "Save & Continue" button even if the "Is minor edit" checkbox is cleared
      XWIKI-10944"Is a minor edit" option is wrong displayed everywhere on ie8
      XWIKI-2194Provide Default Option for the minor edit checkbox
      XWIKI-9940History button shows "Hide minor edits" even if "showminor=false"
      XWIKI-2845User profile update should be saved as minor edit by LDAP authentication
      XWIKI-8552Make the "Version summary" field and the "Is minor edit" checkbox available in "Preview" mode

      Description

      Implement minor edit support. http://en.wikipedia.org/wiki/Minor_edit

      New checkbox "Minor edit" will be added to document edit form
      Minor changes will be hidden in history UI by default
      It will be stored as normal changes with special mark (doc.isMinorEdit)
      Minor versions will increase 2nd version number. Major - 1st. (ex: 1.1-minor-1.2-major- 2.1-minor- 2.2)
      Adding objects,attachments,comments,rights to document is minor changes.

      Implementation is the same as XWIKI-114

      1. XWIKI-1447-r3.patch
        6 kB
        Artem Melentev
      2. xwiki-platform-core-XWIKI-1447-r0.patch
        15 kB
        Artem Melentev
      3. xwiki-platform-web-XWIKI-1447-r0.patch
        2 kB
        Artem Melentev
      4. xwiki-platform-web-XWIKI-1447-r1.patch
        4 kB
        Artem Melentev
      1. minorEditCheckboxAtLeft.jpg
        48 kB

        Issue Links

          Activity

          Artem Melentev made changes -
          Field Original Value New Value
          Assignee Artem Melentev [ amelentev ]
          Artem Melentev made changes -
          Status Open [ 1 ] In Progress [ 3 ]
          Artem Melentev made changes -
          Fix Version/s 1.1 M3 [ 10236 ]
          Artem Melentev added a comment -

          Minor versions will be named like 1.2.3 (major - 1.2)

          Artem Melentev made changes -
          Description Implement minor edit support. http://en.wikipedia.org/wiki/Minor_edit

          New checkbox "Minor edit" will be added to document edit form
          Minor changes will be hidden in history UI by default
          It will be stored as normal changes with special mark (doc.isMinorEdit)

          Implementation is the same as XWIKI-114
          Implement minor edit support. http://en.wikipedia.org/wiki/Minor_edit

          New checkbox "Minor edit" will be added to document edit form
          Minor changes will be hidden in history UI by default
          It will be stored as normal changes with special mark (doc.isMinorEdit)
          Minor versions will be named like 1.2.3 (major - 1.2)

          Implementation is the same as XWIKI-114
          Artem Melentev made changes -
          Artem Melentev added a comment -

          First preview version patches attached

          Artem Melentev made changes -
          Artem Melentev added a comment -

          Minor versions will increase 2nd version number. Major - 1st. (ex: 1.1-minor-1.2-major- 2.1-minor- 2.2)

          Artem Melentev made changes -
          Description Implement minor edit support. http://en.wikipedia.org/wiki/Minor_edit

          New checkbox "Minor edit" will be added to document edit form
          Minor changes will be hidden in history UI by default
          It will be stored as normal changes with special mark (doc.isMinorEdit)
          Minor versions will be named like 1.2.3 (major - 1.2)

          Implementation is the same as XWIKI-114
          Implement minor edit support. http://en.wikipedia.org/wiki/Minor_edit

          New checkbox "Minor edit" will be added to document edit form
          Minor changes will be hidden in history UI by default
          It will be stored as normal changes with special mark (doc.isMinorEdit)
          Minor versions will increase 2nd version number. Major - 1st. (ex: 1.1-minor-1.2-major- 2.1-minor- 2.2)

          Implementation is the same as XWIKI-114
          Artem Melentev added a comment -

          added show/hide minor edits in history view.

          Artem Melentev made changes -
          Artem Melentev added a comment -

          Adding objects,attachments,comments,rights to document is minor changes.

          Artem Melentev made changes -
          Description Implement minor edit support. http://en.wikipedia.org/wiki/Minor_edit

          New checkbox "Minor edit" will be added to document edit form
          Minor changes will be hidden in history UI by default
          It will be stored as normal changes with special mark (doc.isMinorEdit)
          Minor versions will increase 2nd version number. Major - 1st. (ex: 1.1-minor-1.2-major- 2.1-minor- 2.2)

          Implementation is the same as XWIKI-114
          Implement minor edit support. http://en.wikipedia.org/wiki/Minor_edit

          New checkbox "Minor edit" will be added to document edit form
          Minor changes will be hidden in history UI by default
          It will be stored as normal changes with special mark (doc.isMinorEdit)
          Minor versions will increase 2nd version number. Major - 1st. (ex: 1.1-minor-1.2-major- 2.1-minor- 2.2)
          Adding objects,attachments,comments,rights to document is minor changes.

          Implementation is the same as XWIKI-114
          Artem Melentev added a comment -

          The problem is "what's new" page in XE. How to find latest major change of document? Maybe we need doc.majorEditDate() and doc.latestMajorAuthor()

          Sergiu Dumitriu added a comment -

          Since minorEdit must be in the hibernate mapping, then you can check it in the query, "... and doc.minorEdit = 0 ..."

          Artem Melentev added a comment -

          2Sergiu:
          By the current versioning store, only last version of document is stored in DB (and archive is stored in document), so if somebody do major edit and next minor edit, we skip this document with hsql "... and doc.minorEdit = 0 ..." (I think it is wrong, because major edit was done )

          To make it work I need to implement "keep document history in a separate table" before this task.
          I think it will be version cache table (as ludovic offer in http://www.nabble.com/-Proposal--Document-history-storage-tf3310594.html#a9209023) + storing whole document foreach of ~50 versions + latest version

          Artem Melentev made changes -
          Link This issue depends on XWIKI-1459 [ XWIKI-1459 ]
          Artem Melentev made changes -
          Fix Version/s 1.1 M4 [ 10237 ]
          Fix Version/s 1.1 M3 [ 10236 ]
          Affects Version/s 1.1 M1 [ 10221 ]
          Artem Melentev made changes -
          Due Date 2007-07-21 00:00:00.0
          Artem Melentev added a comment -

          hql query for major only what's new:

          select distinct doc.web, doc.name from XWikiDocument as doc, XWikiRCSNodeInfo as ni
            where doc.id=ni.id.docId and ni.id.version2=1
            group by doc.web, doc.name
            order by max(ni.date) desc
          

          (versions like x.1 is major edits)
          I don't find easyer hql for this.

          Artem Melentev added a comment -

          Attached XWIKI-1447-r3.patch - new revision of UI. code in XWIKI-1459.
          Main.Dashboard show documents order by major change date by default.

          Artem Melentev made changes -
          Attachment XWIKI-1447-r3.patch [ 11269 ]
          amelentev
          07/Aug/07 22:44
          View full commit
          XWIKI-1459: keep document history in a separate table - fixed XWIKI-1468: History page version and normal page version do not match - fixed XWIKI-962: Ability to alter the document history - only code XWIKI-1447: Minor edit of document - only code New histore storage implemented. It is quate hard to separate this issues now. git-svn-id: https://svn.xwiki.org/svnroot/xwiki/xwiki-products/xwiki-enterprise/trunk@4119 f329d543-caf0-0310-9063-dda96c69346f
          Artem Melentev added a comment -

          fixed in r4120

          Artem Melentev made changes -
          Status In Progress [ 3 ] Closed [ 6 ]
          Resolution Fixed [ 1 ]
          Artem Melentev made changes -
          Link This issue is related to XE-95 [ XE-95 ]
          Vincent Massol added a comment -

          Artem I guess this means the idea is that these changes don't appear in the What's New either is that right?

          Also how will I be able to see all changes?

          The reason I ask this is that I'm watching over xwiki.org every day and I need to know if someone has made a change, and adding a new object to a page happens frequently is a major change that I need to revert (like when a user adds a new right to a page). What will be the process I can use now to ensure I see all changes easily?

          Thanks
          -Vincent

          Artem Melentev added a comment -

          Vincent, I modified only Main.Dashboard in XE-95. Main.WhatsNew show all changes as before.
          Main.Dashboard has a switch show/hide minor edits. By default only major edits is shown.
          Maybe we need to save user preference about show or hide minor edits in user's profile. WDYT?

          Artem Melentev made changes -
          Attachment minorEditCheckboxAtLeft.jpg [ 11320 ]
          Vincent Massol added a comment -

          Maybe we need to save user preference about show or hide minor edits in user's profile. WDYT?

          I think what you've done so far is good. Let's keep it simple for now and see how it goes. I'll let you know how it goes after I use it for real on xwiki.org and we can always devise ways of improving visibility for those who require it.

          Thanks

          Vincent Massol added a comment -

          Artem,

          Just tested minor edits and it's not working for me. I simply ran the full build and installed the XE standalone version. Here's what I did:

          • edited home page and clicked on "minor edit" + added a comment
          • clicked on "What's new"

          I could see my change in the list and when I clicked on "show minor edits" it showed a bunch of other changes which were never marked as minor edits I believe.

          Also you need to use an uppercase "S" in "show minor edits" as in English first letter of sentences are in uppercase.

          Thanks
          -Vincent

          Vincent Massol added a comment -

          reopen for now as it's not working for me)

          Vincent Massol made changes -
          Status Closed [ 6 ] Reopened [ 4 ]
          Resolution Fixed [ 1 ]
          Artem Melentev added a comment -

          Vincent,
          xe-database module produce old database (it is use core-1.1M2), so history (xwikircs table) will be empty. If you will import xar by new core, all will be fine.
          This problem will be fixed if we write migration (XWIKI-1569) for this issue (I do it now).

          Vincent Massol added a comment -

          If XE Database is moved to core-1.1M4 will it work? If so then why don't we do this?

          I mean right now, from a user point of view, this feature is NOT working, as they'll expect something that works when they download the XE standalone version. They should NOT have to run any migration tool if they install 1.1M4 standalone of course

          Could you fix that?

          -Vincent

          Artem Melentev added a comment -

          So you propose to use xwiki-core-SNAPSHOT in xe-database module? This will resolve this problem.
          But this issue can't be included in 1.1M4 because it depends on XWIKI-1459 which need be reverted before 1.1M4 ?

          Artem Melentev added a comment -

          rollback

          Artem Melentev made changes -
          Fix Version/s Future [ 10210 ]
          Fix Version/s 1.1 M4 [ 10237 ]
          Artem Melentev made changes -
          Fix Version/s 1.2 M1 [ 10351 ]
          Fix Version/s Future [ 10210 ]
          Artem Melentev added a comment -

          fixed again in r4361

          Artem Melentev made changes -
          Resolution Fixed [ 1 ]
          Status Reopened [ 4 ] Closed [ 6 ]
          Vincent Massol made changes -
          Link This issue relates to XWIKI-1856 [ XWIKI-1856 ]

            People

            • Assignee:
              Artem Melentev
              Reporter:
              Artem Melentev
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Due:
                Created:
                Updated:
                Resolved:
                Date of First Response: