Details

    • Type: Improvement Improvement
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.8.3, 1.9 M2
    • Fix Version/s: 3.0 M3
    • Component/s: WYSIWYG Editor
    • Labels:
      None
    • Environment:
      Safari
    • keywords:
      safari
    • Difficulty:
      Hard
    • Similar issues:
      XWIKI-3497Add support for Opera browser
      XWIKI-2266Safari Wysiwyg editor support
      XWIKI-4295Add support for specific stylesheets for IE browsers
      XWIKI-713Crash safari when add xwiki-1.0-beta-2.xar
      XWIKI-5915Cannot log in using Safari
      XWIKI-6428IE6 browser compatibility
      XWIKI-6547Using Wysiwyg editor with Safari browser: Formatting causes cursor to jump back to top left position of edit pane
      XWIKI-99Add support for removing class properties
      XWIKI-4944Add support for Default Values for XWiki Wiki Macros
      XWIKI-4132Add macro categories support for wiki macros

      Issue Links

        Activity

        Marius Dumitru Florea added a comment - - edited

        Here's a list of issues found on Safari 3.1.2 (525.21) 4.0.4 (531.21.10):

        1. underline + strike through doesn't work when the tool bar buttons are used
        2. can't move the caret before the first letter of styled text (bold, italic, etc.) (not supported)
        3. can't place the caret at the start of an in-line element (click bold button when there's no selection but the caret) (not supported)
        4. selection is collapsed at its end when an operation is impossible (underline+strike through, subscript+superscript, etc.)
        5. subscript + superscript doesn't work (only one of them is allowed)
        6. remove sub/superscript doesn't work
        7. blur/focus problems (by clicking on unordered list 3 times the rich text area looses the focus)
        8. rich text area is blurred on load even when the browser window has focus
        9. problem with empty blocks (paragraphs, headings); a BR might be needed; as a consequence empty paragraphs and headings can't be created
        10. insert two symbols; the second is inserted before the first
        11. shift+tab on a first level list item blurs the rich text area
        12. delete table blurs the rich text area
        13. refresh macro doesn't focus the rich text area
        14. macros are not detected
        15. cannot select or resize an image with the mouse (resize handlers missing) (not supported)
        16. element meta data is not handled properly, making links, macros and images almost unusable
        17. pressing enter in complex list item doesn't create a new list item but splits the block containing the caret (default behaviour)
        18. Safari adds classes to some elements: class="Apple-style-span"
        19. pressing backspace keeps the style but not the markup: deleting a heading with backspace keeps the heading style but not the h1 markup
        20. edit in full screen doesn't work
        21. sometimes the editor fails loading and the error console displays "Null value"
        22. the saved content is ignored: the rich text area is empty after the editor finished loading
        Vincent Massol added a comment -

        Marius, is this list valid for Safari 4 too or are there more things to fix?

        Marius Dumitru Florea added a comment -

        Vincent, I haven't tested on Safari 4 yet. Currently I'm testing on Epiphany+WebKit (the latest WebKit I think, since I get often updates from https://launchpad.net/~webkit-team/+archive/ppa ). We have Safari 4.03 installed on a Windows machine. I'll test as soon as I get the time.

        Guillaume Laforge added a comment - - edited

        Another issue with Safari 4 seems to be the absence of focus in dialog box text fields.

        For instance, if I do the following:

        • write some text
        • select a word
        • click on the link menu
        • click on the web page item

        Then the dialog box appears, and I would expect the focus to be by default in the field where I'd like to enter the URL.
        Vincent told me it's working elsewhere (ie. in Firefox) but is probably not working in Safari 4.

        (I'm using Safari 4 on my Leopard MBP)

        Guillaume Laforge added a comment -

        Another issue related to my previous comment.

        When I follow the same scenario as previously, I select a word to add a link to it, but the decide to not add any link, and directly close the dialog box with the cross, then I got back to the normal editing view, but my selection has disappeared.

        I think the selected text should stay selected, even if I don't add a link.

        Marius Dumitru Florea added a comment -

        Guillaume, I can reproduce the focus problem but the selection is preserved when I close the link dialog using the cross. I'm testing with 4.0.4 (531.21.10) on Windows XP.

        Marius Dumitru Florea added a comment -

        The glass panel ( http://code.google.com/p/google-web-toolkit-incubator/wiki/GlassPanel ) steals the focus from the dialog box even if the dialog box focuses its first input field using a deferred command.

        Marius Dumitru Florea added a comment -

        The missing focus issue has been fixed by XWIKI-5857.

        Marius Dumitru Florea added a comment -

        Closing this issue for 3.0M3. From now on Safari/Chrome issues should be reported separately.


          People

          • Assignee:
            Marius Dumitru Florea
            Reporter:
            Marius Dumitru Florea
          • Votes:
            1 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:
              Date of First Response: