XWiki Platform
  1. XWiki Platform
  2. XWIKI-6513

Current Space in NewPage Panel Seems Unintuitive to Novice Users

    Details

    • Type: Improvement Improvement
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Cannot Reproduce
    • Affects Version/s: 1.8
    • Fix Version/s: None
    • Component/s: Panels
    • Labels:
      None
    • keywords:
      ux
    • Similar issues:
      XWIKI-6506"New Child Page" - option for NewPage panel that sets a NewPage's parent to be the current (last) document.
      XWIKI-8382NewPage Panel doesn't work anymore
      XWIKI-9872Add an option to disable panels on a space webhome
      XWIKI-3513Suggest JS widget doesn't provide suggestion for spaces: XWiki, Panels, etc.
      XWIKI-2695Can't seem to disable Registration Link in 1.5.2
      XWIKI-3807Extend rights management to assign rights to create and delete spaces
      XWIKI-6509Add space selection combo box to the "Create" Panel
      XWIKI-4117Panel in syntax 2.0 does not render when current doc has 1.0 syntax
      XWIKI-8466Panels don't expand/collapse on the "Panel Wizard" page on IE8 and Chrome

      Description

      A user creates a new page using the NewPage Panel by entering the page name in the field and clicking on the Create button. A note is permanently displayed stating 'New pages are created in current space'. This behavior may be misleading, especially to novice users, since it is not always easy for users to determine the current space. In particular, the current space is not displayed in the NewPage Panel itself, so the user has to look around elsewhere in the interface to read this information. It would be better to explicitly display the current space name in the NewPage Panel interface. A more general interface would allow for choosing a space to create a new page in and maybe event to create a new space on the fly, maybe by a mechanism similar to the labels list in gmail.

        Issue Links

          Activity

          Jean-Vincent Drean added a comment -

          Since we are refactoring our UI with colibri I suggest to close this issue as won't fix. WDYT ?
          I'm assigning myself to keep track of the issue.

          Vincent Massol added a comment -

          yes it's a won't fix since we now have a menu entry for creating new pages/spaces and in some future we'll use that as well to create new document types I believe.

          Ecaterina Moraru (Valica) added a comment -

          In XE 2.3 the space field is completed so the issue must have been fixed meanwhile.
          For the second part, the selection of the space, where is already another issue XWIKI-6509


            People

            • Assignee:
              Ecaterina Moraru (Valica)
              Reporter:
              Luis Arias
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:
                Date of First Response: