XWiki Platform
  1. XWiki Platform
  2. XWIKI-6712

"Last modifications feed for your watchlist" RSS link on a user's profile page is non-functional

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 3.1 RC1
    • Fix Version/s: 3.2 M1, 3.1.1
    • Component/s: None
    • Labels:
      None
    • Environment:
      Kernel: 2.6.32-131.2.1.el6.x86_64
      Most recent release of Scientific Linux
      On a VMware virtual machine with 2GB of RAM allocated.
    • keywords:
      rss,profile,watchlistrss,parser
    • Difficulty:
      Unknown
    • Similar issues:
      XWIKI-8432Watchlist RSS Feed downloads file on IE and Chrome
      XWIKI-268WatchList : notifications by email when documents are updated + associated rss feed
      XWIKI-1822Write a watchlist plugin from sandbox's notification plugin
      XWIKI-9981Clicking on the "Change password" button discards all your other profile modifications
      XWIKI-11201Users can render the User Directory non-functional by editing their profile
      XWIKI-2004Improve description of Watchlist RSS feed so specify it's a modifications feed
      XWIKI-448Refactor and Improve RSS Feed Generation in XWiki
      XWIKI-226The title and the description of the Wiki RSS feed should be in the preferences.
      XWIKI-835Links to web and blog rss feeds should not be rendered on login page if not visible by XWikiGuest
      XWIKI-5675Missing translations for WatchList RSS feed for the new add, update, delete for Comment, Attachment, Annotation events

      Description

      When a user clicks on the "Last modifications feed for your watchlist" RSS link on their profile, they are prompted to download a file named "WatchListRss". This file contains the following:

      WatchListRss
      Failed to execute the [velocity] macroorg.xwiki.rendering.macro.MacroExecutionException: Failed to evaluate Velocity Macro for content [## WatchList RSS.
      ## This page must be called with the following query string: "?xpage=plain&outputSyntax=plain"
      #if("$!request.xpage" != "plain" && "$!request.outputSyntax" != "plain")
      WatchList RSS feed
      #else
      $!response.setContentType("application/text+xml")##
      #set($feed = $xwiki.watchlist.getFeed(20))##
      #set($discard = $feed.set)
      $xwiki.feed.getFeedOutput($xwiki.watchlist.getFeed(20), "rss_2.0")##
      #end]
      	at org.xwiki.rendering.internal.macro.velocity.VelocityMacro.evaluateString(VelocityMacro.java:133)
      	at org.xwiki.rendering.internal.macro.velocity.VelocityMacro.evaluateString(VelocityMacro.java:49)
      	at org.xwiki.rendering.macro.script.AbstractScriptMacro.evaluateBlock(AbstractScriptMacro.java:306)
      	at org.xwiki.rendering.macro.script.AbstractScriptMacro.execute(AbstractScriptMacro.java:202)
      	at org.xwiki.rendering.macro.script.AbstractScriptMacro.execute(AbstractScriptMacro.java:59)
      	at org.xwiki.rendering.internal.transformation.macro.MacroTransformation.transformOnce(MacroTransformation.java:196)
      	at org.xwiki.rendering.internal.transformation.macro.MacroTransformation.transform(MacroTransformation.java:141)
      	at org.xwiki.rendering.internal.transformation.DefaultTransformationManager.performTransformations(DefaultTransformationManager.java:81)
      	at com.xpn.xwiki.doc.XWikiDocument.performSyntaxConversion(XWikiDocument.java:7639)
      	at com.xpn.xwiki.doc.XWikiDocument.performSyntaxConversion(XWikiDocument.java:7588)
      	at com.xpn.xwiki.doc.XWikiDocument.getRenderedContent(XWikiDocument.java:838)
      	at com.xpn.xwiki.doc.XWikiDocument.getRenderedContent(XWikiDocument.java:787)
      	at com.xpn.xwiki.api.Document.getRenderedContent(Document.java:626)
      	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      	at java.lang.reflect.Method.invoke(Method.java:597)
      	at org.apache.velocity.util.introspection.UberspectImpl$VelMethodImpl.doInvoke(UberspectImpl.java:395)
      	at org.apache.velocity.util.introspection.UberspectImpl$VelMethodImpl.invoke(UberspectImpl.java:384)
      	at org.apache.velocity.runtime.parser.node.ASTMethod.execute(ASTMethod.java:173)
      	at org.apache.velocity.runtime.parser.node.ASTReference.execute(ASTReference.java:280)
      	at org.apache.velocity.runtime.parser.node.ASTReference.render(ASTReference.java:369)
      	at org.apache.velocity.runtime.parser.node.ASTBlock.render(ASTBlock.java:72)
      	at org.apache.velocity.runtime.parser.node.ASTIfStatement.render(ASTIfStatement.java:87)
      	at org.apache.velocity.runtime.parser.node.SimpleNode.render(SimpleNode.java:342)
      	at org.xwiki.velocity.internal.DefaultVelocityEngine.evaluate(DefaultVelocityEngine.java:195)
      	at org.xwiki.velocity.internal.DefaultVelocityEngine.evaluate(DefaultVelocityEngine.java:160)
      	at com.xpn.xwiki.render.XWikiVelocityRenderer.evaluate(XWikiVelocityRenderer.java:116)
      	at com.xpn.xwiki.XWiki.evaluateTemplate(XWiki.java:1840)
      	at com.xpn.xwiki.XWiki.parseTemplate(XWiki.java:1778)
      	at com.xpn.xwiki.api.XWiki.parseTemplate(XWiki.java:836)
      	at sun.reflect.GeneratedMethodAccessor110.invoke(Unknown Source)
      	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      	at java.lang.reflect.Method.invoke(Method.java:597)
      	at org.apache.velocity.util.introspection.UberspectImpl$VelMethodImpl.doInvoke(UberspectImpl.java:395)
      	at org.apache.velocity.util.introspection.UberspectImpl$VelMethodImpl.invoke(UberspectImpl.java:384)
      	at org.apache.velocity.runtime.parser.node.ASTMethod.execute(ASTMethod.java:173)
      	at org.apache.velocity.runtime.parser.node.ASTReference.execute(ASTReference.java:280)
      	at org.apache.velocity.runtime.parser.node.ASTReference.render(ASTReference.java:369)
      	at org.apache.velocity.runtime.parser.node.ASTBlock.render(ASTBlock.java:72)
      	at org.apache.velocity.runtime.directive.VelocimacroProxy.render(VelocimacroProxy.java:216)
      	at org.apache.velocity.runtime.directive.RuntimeMacro.render(RuntimeMacro.java:311)
      	at org.apache.velocity.runtime.directive.RuntimeMacro.render(RuntimeMacro.java:230)
      	at org.apache.velocity.runtime.parser.node.ASTDirective.render(ASTDirective.java:207)
      	at org.apache.velocity.runtime.parser.node.ASTBlock.render(ASTBlock.java:72)
      	at org.apache.velocity.runtime.parser.node.SimpleNode.render(SimpleNode.java:342)
      	at org.apache.velocity.runtime.parser.node.ASTIfStatement.render(ASTIfStatement.java:106)
      	at org.apache.velocity.runtime.parser.node.SimpleNode.render(SimpleNode.java:342)
      	at org.xwiki.velocity.internal.DefaultVelocityEngine.evaluate(DefaultVelocityEngine.java:195)
      	at org.xwiki.velocity.internal.DefaultVelocityEngine.evaluate(DefaultVelocityEngine.java:160)
      	at com.xpn.xwiki.render.XWikiVelocityRenderer.evaluate(XWikiVelocityRenderer.java:116)
      	at com.xpn.xwiki.XWiki.evaluateTemplate(XWiki.java:1840)
      	at com.xpn.xwiki.web.Utils.parseTemplate(Utils.java:153)
      	at com.xpn.xwiki.web.XWikiAction.execute(XWikiAction.java:224)
      	at com.xpn.xwiki.web.XWikiAction.execute(XWikiAction.java:115)
      	at org.apache.struts.action.RequestProcessor.processActionPerform(RequestProcessor.java:431)
      	at org.apache.struts.action.RequestProcessor.process(RequestProcessor.java:236)
      	at org.apache.struts.action.ActionServlet.process(ActionServlet.java:1196)
      	at org.apache.struts.action.ActionServlet.doGet(ActionServlet.java:414)
      	at javax.servlet.http.HttpServlet.service(HttpServlet.java:621)
      	at javax.servlet.http.HttpServlet.service(HttpServlet.java:722)
      	at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:304)
      	at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:210)
      	at com.xpn.xwiki.web.ActionFilter.doFilter(ActionFilter.java:129)
      	at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:243)
      	at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:210)
      	at org.xwiki.wysiwyg.server.filter.ConversionFilter.doFilter(ConversionFilter.java:152)
      	at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:243)
      	at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:210)
      	at com.xpn.xwiki.plugin.webdav.XWikiDavFilter.doFilter(XWikiDavFilter.java:68)
      	at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:243)
      	at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:210)
      	at org.xwiki.container.servlet.filters.internal.SavedRequestRestorerFilter.doFilter(SavedRequestRestorerFilter.java:218)
      	at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:243)
      	at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:210)
      	at org.xwiki.container.servlet.filters.internal.SetCharacterEncodingFilter.doFilter(SetCharacterEncodingFilter.java:112)
      	at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:243)
      	at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:210)
      	at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:240)
      	at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:164)
      	at org.apache.catalina.authenticator.AuthenticatorBase.invoke(AuthenticatorBase.java:462)
      	at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:164)
      	at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:100)
      	at org.apache.catalina.valves.AccessLogValve.invoke(AccessLogValve.java:563)
      	at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:118)
      	at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:399)
      	at org.apache.coyote.ajp.AjpProcessor.process(AjpProcessor.java:303)
      	at org.apache.coyote.ajp.AjpProtocol$AjpConnectionHandler.process(AjpProtocol.java:183)
      	at org.apache.coyote.ajp.AjpProtocol$AjpConnectionHandler.process(AjpProtocol.java:169)
      	at org.apache.tomcat.util.net.JIoEndpoint$SocketProcessor.run(JIoEndpoint.java:311)
      	at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886)
      	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)
      	at java.lang.Thread.run(Thread.java:662)
      Caused by: org.xwiki.velocity.XWikiVelocityException: Failed to evaluate content with id [xwiki:XWiki.WatchListRss]
      	at org.xwiki.velocity.internal.DefaultVelocityEngine.evaluate(DefaultVelocityEngine.java:204)
      	at org.xwiki.velocity.internal.DefaultVelocityEngine.evaluate(DefaultVelocityEngine.java:160)
      	at org.xwiki.rendering.internal.macro.velocity.VelocityMacro.evaluateString(VelocityMacro.java:126)
      	... 92 more
      Caused by: org.apache.velocity.exception.MethodInvocationException: Invocation of method 'getFeed' in  class com.xpn.xwiki.plugin.watchlist.WatchListPluginApi threw exception com.xpn.xwiki.plugin.activitystream.api.ActivityStreamException: Error number 3223 in 3: Error number 3223 in 3: Exception while searching documents with sql select act from ActivityEventImpl as act  where act.wiki in () or concat(act.wiki,:,act.space) in (?) or concat(act.wiki,:,act.page) in (?,?,?,?,?,?,?) order by act.date desc
      Wrapped Exception: unexpected end of subtree [select act from com.xpn.xwiki.plugin.activitystream.impl.ActivityEventImpl as act  where act.wiki in () or concat(act.wiki,:,act.space) in (?) or concat(act.wiki,:,act.page) in (?,?,?,?,?,?,?) order by act.date desc]
      Wrapped Exception: unexpected end of subtree [select act from com.xpn.xwiki.plugin.activitystream.impl.ActivityEventImpl as act  where act.wiki in () or concat(act.wiki,':',act.space) in (?) or concat(act.wiki,':',act.page) in (?,?,?,?,?,?,?) order by act.date desc] at xwiki:XWiki.WatchListRss[line 7, column 31]
      	at org.apache.velocity.runtime.parser.node.ASTMethod.handleInvocationException(ASTMethod.java:243)
      	at org.apache.velocity.runtime.parser.node.ASTMethod.execute(ASTMethod.java:187)
      	at org.apache.velocity.runtime.parser.node.ASTReference.execute(ASTReference.java:280)
      	at org.apache.velocity.runtime.parser.node.ASTReference.value(ASTReference.java:567)
      	at org.apache.velocity.runtime.parser.node.ASTExpression.value(ASTExpression.java:71)
      	at org.apache.velocity.runtime.parser.node.ASTSetDirective.render(ASTSetDirective.java:142)
      	at org.apache.velocity.runtime.parser.node.ASTBlock.render(ASTBlock.java:72)
      	at org.apache.velocity.runtime.parser.node.SimpleNode.render(SimpleNode.java:342)
      	at org.apache.velocity.runtime.parser.node.ASTIfStatement.render(ASTIfStatement.java:106)
      	at org.apache.velocity.runtime.parser.node.SimpleNode.render(SimpleNode.java:342)
      	at org.xwiki.velocity.internal.DefaultVelocityEngine.evaluate(DefaultVelocityEngine.java:195)
      	... 94 more
      Caused by: com.xpn.xwiki.plugin.activitystream.api.ActivityStreamException: Error number 3223 in 3: Error number 3223 in 3: Exception while searching documents with sql select act from ActivityEventImpl as act  where act.wiki in () or concat(act.wiki,:,act.space) in (?) or concat(act.wiki,:,act.page) in (?,?,?,?,?,?,?) order by act.date desc
      Wrapped Exception: unexpected end of subtree [select act from com.xpn.xwiki.plugin.activitystream.impl.ActivityEventImpl as act  where act.wiki in () or concat(act.wiki,:,act.space) in (?) or concat(act.wiki,:,act.page) in (?,?,?,?,?,?,?) order by act.date desc]
      Wrapped Exception: unexpected end of subtree [select act from com.xpn.xwiki.plugin.activitystream.impl.ActivityEventImpl as act  where act.wiki in () or concat(act.wiki,':',act.space) in (?) or concat(act.wiki,':',act.page) in (?,?,?,?,?,?,?) order by act.date desc]
      	at com.xpn.xwiki.plugin.activitystream.impl.ActivityStreamImpl.searchEvents(ActivityStreamImpl.java:663)
      	at com.xpn.xwiki.plugin.activitystream.plugin.ActivityStreamPluginApi.searchEvents(ActivityStreamPluginApi.java:307)
      	at com.xpn.xwiki.plugin.watchlist.WatchListEventFeedManager.getFeed(WatchListEventFeedManager.java:90)
      	at com.xpn.xwiki.plugin.watchlist.WatchListPluginApi.getFeed(WatchListPluginApi.java:407)
      	at com.xpn.xwiki.plugin.watchlist.WatchListPluginApi.getFeed(WatchListPluginApi.java:396)
      	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      	at java.lang.reflect.Method.invoke(Method.java:597)
      	at org.apache.velocity.util.introspection.UberspectImpl$VelMethodImpl.doInvoke(UberspectImpl.java:395)
      	at org.apache.velocity.util.introspection.UberspectImpl$VelMethodImpl.invoke(UberspectImpl.java:384)
      	at org.apache.velocity.runtime.parser.node.ASTMethod.execute(ASTMethod.java:173)
      	... 103 more
      

      And in my catalina.out, I see:

      catalina.out
      2011-06-16 13:25:41,254 [https://<DOMAIN>/xwiki/bin/view/XWiki/WatchListRss?xpage=plain&outputSyntax=plain] ERROR o.h.h.PARSER                   - <AST>:0:0: unexpected end of subtree
      

      This line appears a LOT in the logfile.

        Activity

        Sergiu Dumitriu added a comment -

        Fixed in 32f3a44


          People

          • Assignee:
            Sergiu Dumitriu
            Reporter:
            Paul Martin
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:
              Date of First Response: