XWiki Platform
  1. XWiki Platform
  2. XWIKI-6736

Error at startup when some modification having empty user as author is saved

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 3.1
    • Fix Version/s: 3.2 M1, 3.1.1
    • Component/s: Watchlist
    • Labels:
      None
    • Difficulty:
      Unknown
    • Similar issues:
      XWIKI-5894Incorrect author when saving document in a different wiki.
      XWIKI-818When registering, the user page does not have the creator/author properties set
      XWIKI-9213Wrong author get saved in the DB
      XWIKI-5432empty title in section editing blocks saving when titles are mandatory
      XWIKI-8620XWiki.WatchListClass class is re-saved at each startup
      XWIKI-7936When you import a page, that have no attachment and overwrite an existing page containing attachments, some errors appear with them.
      XWIKI-9287Intermittent Solr error at startup
      XWIKI-3585Saving a modification with a lost page lock should warn the user.
      XWIKI-6553Adding a tag does not save the proper author in the minor version
      XWIKI-7802The list of always used extensions on a wiki is not properly updated when a doc is saved with programming rights

      Description

      It's just an error printed but empty user should be skipped like any other non existing user.

        Activity

        Vincent Massol added a comment -

        Shouldn't the root caused be fixed instead, ie we shouldn't have an empty user?

        Thomas Mortagne added a comment - - edited

        Having empty user in a document is technically possible and has been made on purpose in this case AFAIK (saving the document with a user that can't have programming right) so the autowatchlist should support it and not print an error.

        Vincent Massol added a comment -

        How can you send a watchlist mail if you don't know the user?

        Thomas Mortagne added a comment - - edited

        What this has to do with watchlist ? No mail is sent to this user.


          People

          • Assignee:
            Thomas Mortagne
            Reporter:
            Thomas Mortagne
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:
              Date of First Response: