XWiki Platform
  1. XWiki Platform
  2. XWIKI-7510

XWiki is not able to automatically start OpenOffice daemon on Windows Server

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Incomplete
    • Affects Version/s: 3.2.1
    • Fix Version/s: None
    • Component/s: Office
    • Labels:
    • Difficulty:
      Unknown
    • Documentation:
      N/A
    • Documentation in Release Notes:
      N/A
    • Similar issues:
      XWIKI-7509XWiki automatically connect to an external openoffice daemon
      XWIKI-3710Add support for automatically restarting OpenOffice server when XE is restarted
      XWIKI-3721Starting an already started openoffice server should be prohibited
      XWIKI-3300Add support for controlling the openoffice server process from XWiki UI
      XWIKI-6132Need to create directory in Tomcat to start the office server
      XWIKI-6819OpenOffice internal-managed integration failed with OOO 3.3
      XWIKI-8799Can't launch LibreOffice server on Windows 7
      XWIKI-7624UI-test suite is unable to start XWiki instance on Windows systems
      XWIKI-4121Restrict openoffice server manipulations to main xwiki
      XWIKI-6883Automatically open the browser when launching start_xwiki

      Description

      At this time xwiki is not able to automatically start OpenOffice daemon on a Windows Server.

        Issue Links

          Activity

          Alexandru Stancu made changes -
          Field Original Value New Value
          Component/s Office [ 10740 ]
          Florin Ciubotaru added a comment -

          Hi Alex. I'm trying to reproduce this. Can you post some details about the environment?

          • is OOo externally managed?
          • is the servlet container running as a regular process or as a service? Is it runnning under an administrator user?
          • if it's a service is it interactive or non-interactive?
            Thanks.
          Vincent Massol made changes -
          Affects Version/s 3.2.1 [ 12556 ]
          Ecaterina Moraru (Valica) added a comment -

          Incomplete. Could be a duplicate of XWIKI-8093, but OpenOffice.org 2.2 should work fine

          Ecaterina Moraru (Valica) made changes -
          Status Open [ 1 ] Closed [ 6 ]
          Documentation N/A
          Assignee Ecaterina Moraru (Valica) [ evalica ]
          Documentation in Release Notes N/A
          Resolution Incomplete [ 4 ]
          Ecaterina Moraru (Valica) made changes -
          Link This issue duplicates XWIKI-8093 [ XWIKI-8093 ]
          Ecaterina Moraru (Valica) made changes -
          Labels bugfixingday

            People

            • Assignee:
              Ecaterina Moraru (Valica)
              Reporter:
              Alexandru Stancu
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:
                Date of First Response: