Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Blocker Blocker
    • Resolution: Duplicate
    • Affects Version/s: 3.4, 3.3.1
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None
    • Environment:
      postgresql-9.0.6-1, postgresql-9.0-802.jdbc4.jar
    • Difficulty:
      Unknown
    • Similar issues:
      XWIKI-6212Images not displayed in the administration of xwiki 3.0
      XWIKI-9358Move to Servlet 3.0
      XWIKI-1610WYSIWYG editor bugs on Safari 3.0
      XWIKI-1915The new user, groups and rights management has some bugs in Firefox 3.0 beta1
      XWIKI-906Update TinyMCE to version 3.0
      XWIKI-5265Upgrade to JODConverter 3.0 beta3
      XWIKI-7299Upgrade platform to use SmartGWT 3.0
      XWIKI-2677GWT RPC requests do not work with basic authentication
      XWIKI-5580Upgrade extension manager maven dependency to 3.0
      XWIKI-3326Two versions of xmlrpc-client are pulled in the dependency tree

      Description

      I'm getting same exception when upgrading from 3.1.1 as described in
      http://jira.xwiki.org/browse/XWIKI-7388

      Adding
      <property name="jdbc.use_streams_for_binary">false</property>
      into hibernate.cfg.xml does not have any effect

      Adding
      <typedef name="materialized_clob" class="org.hibernate.type.StringClobType" />
      into xwiki.hbm.xml helps to display and edit, but xar importing and file attaching dies

      org.hibernate.HibernateException: Failed to commit or rollback transaction. Root cause [ SQL next exception = [org.postgresql.util.PSQLException: ERROR: column "xwa_content" is of type bytea but expression is
      of type bigint
        Rada: You will need to rewrite or cast the expression.
        Pozice: 67]]
              at com.xpn.xwiki.store.XWikiHibernateBaseStore.endTransaction(XWikiHibernateBaseStore.java:876) ~[xwiki-platform-legacy-oldcore-3.4.jar:na]
              at com.xpn.xwiki.store.XWikiHibernateBaseStore.endTransaction(XWikiHibernateBaseStore.java:840) ~[xwiki-platform-legacy-oldcore-3.4.jar:na]
              at com.xpn.xwiki.store.XWikiHibernateStore.saveXWikiDoc(XWikiHibernateStore.java:683) ~[xwiki-platform-legacy-oldcore-3.4.jar:na]
              ... 49 common frames omitted
      Caused by: org.hibernate.exception.SQLGrammarException: Could not execute JDBC batch update
              at org.hibernate.exception.SQLStateConverter.convert(SQLStateConverter.java:92) ~[hibernate-core-3.6.9.Final.jar
      :3.6.9.Final]
              at org.hibernate.exception.JDBCExceptionHelper.convert(JDBCExceptionHelper.java:66) ~[hibernate-core-3.6.9.Final.jar:3.6.9.Final]
              at org.hibernate.jdbc.AbstractBatcher.executeBatch(AbstractBatcher.java:275) ~[hibernate-core-3.6.9.Final.jar:3.6.9.Final]
      

        Issue Links

          Activity

          Martin Vanek added a comment -

          Similar results with latest postgresql-9.1.2-1 and postgresql-9.1-901.jdbc4.jar
          xwiki logs "o.h.u.JDBCExceptionReporter - Bad value for type long" exception but displays "The requested document could not be found" page
          Steps:
          Install 3.1.1 xwiki war
          Import default 3.1.1 xar
          Replace 3.1.1 xwiki war with 3.4

          H.-Dirk Schmitt added a comment -

          Same for me with 8.4 database and postgresql-9.1-901.jdbc4.jar
          So i have to revert the upgrade to 3.4

          Sergiu Dumitriu added a comment -

          Duplicate of XWIKI-7564


            People

            • Assignee:
              Sergiu Dumitriu
              Reporter:
              Martin Vanek
            • Votes:
              1 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:
                Date of First Response: