Uploaded image for project: '{RETIRED} XWiki Enterprise'
  1. {RETIRED} XWiki Enterprise
  2. XE-680

Language settings from Administration - General are ignored

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Duplicate
    • Affects Version/s: 2.4 RC1
    • Fix Version/s: None
    • Component/s: None
    • Labels:
    • Documentation:
      N/A
    • Documentation in Release Notes:
      N/A
    • Similar issues:

      Description

      Test Case 1
      Multi Lingual: Yes
      Languages: en, fr, ro
      Default Language : en

      Also because of XE-630, Main.WebHome has multiple translations. All translation (en/zh_TW/ca/de/es/fr/it/lv/nl/ro/sv/uk/zh) for that given page are showed, even though I selected only en, fr, ro (I would have expected just them to be displayed)

      Test Case 2
      Multi Lingual: Yes
      Languages: en, fr, ro
      Default Language : fr

      No effect. The interface is not changed. Also when you create a new page, the default language is still 'en'.

      Maybe is something I don't understand. I would have expected for the language pack to have two sets of controls: one for the content and one for the interface language (maybe I prefer language control, but I do write content in romanian). But apparently in XWiki, when you change the language, you change the content language and the interface control language. That's why if I selected 'fr' as a Default language I would have expected the interface to be actualized in french.

      The behavior and the way languages work is not clear to me. Maybe the labels from administrations could be changed to be more clear.

      Test Case 3
      Multi Lingual: Yes
      Languages:
      Default Language : en

      This test case works only on a fresh instance. I had an instance localhost:8080 where I tested the translations (example: last activated translation was ro). I open another instance localhost:8084, change the fields like above, hit Save, the wiki interface is set in romanian (even if I did not specify nothing about ro). It takes the last value from the cache I assume.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                evalica Ecaterina Moraru (Valica)
                Reporter:
                evalica Ecaterina Moraru (Valica)
              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Date of First Response: