XWiki Enterprise
  1. XWiki Enterprise
  2. XE-728

XWiki forces to crash whole server

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Critical Critical
    • Resolution: Cannot Reproduce
    • Affects Version/s: 2.4.1
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None
    • Environment:
      dedicated debian server (lenny) with mysql, tomcat and xwiki. 1GiB of RAM; running in a virtual ESX machine
    • keywords:
      out of memory,crash
    • Similar issues:
      XE-1150XWiki crashed (due to Scripts?)
      XE-1297Debian package force removing /etc/tomcat*/Catalina/localhost/xwiki.xml file in postrm
      XE-561"Jump to any page in the wiki" doesn't work with cyrillic characters ("Ajax error: Internal Server Error")
      XE-1124Introducing new unix user and group 'xwiki' in debianpackages
      XE-940org.xwiki.test.ui.CreatePageTest.testCreatePageFromTemplate fails on the CI server.
      XE-1342Cannot unzip 5.3-milestone-1 under Windows because some paths are too long
      XE-1268Debian installer does not create the MySQL database with the right collation
      XE-369Weblogic 10.0 doesnt support xwiki-enterprise-web-1.7.1
      XE-412OpenOffice server
      XE-952StorageTests#allTests flickers because an HSQL database lock file is not deleted when the server is shut down.

      Description

      dont't know how to describe what xwiki has done. but it crashed totally.

      in case of there are important information stored inside, it was a critical situation for me. to my luck the xwiki server is a dedicated one.

      i saved all logs from tomcat and xwiki in a seperate file. hope there will be an option to append it after creating this ticket.

      fyi: i created a wiki page with a lot of (40<) latex-formulas and tested the result a lot. maybe this caused the 'out of memory' exception?

      1. office-import-error.txt
        12 kB
        Thomas Steinbach
      2. Skript_Math_Grundlagen.doc
        3.48 MB
        Thomas Steinbach
      3. xwiki bug.7z
        15 kB
        Thomas Steinbach

        Activity

        Thomas Steinbach added a comment -

        all the information i got from the server after the crash

        Thomas Steinbach added a comment -

        maybe the crash was cause by trying to import an office document with special characters. i configurated every instance (xwiki, hibernate, mysql) to utf-8, but every try failed.
        i will also append the alert message after saving the imported document and the document itself.

        Thomas Steinbach added a comment -

        trying to import this .doc may cause the crash of the system

        Thomas Mortagne added a comment -

        In that case it's probably caused by open office and not XWiki. At worst XWiki can maybe crash the JVM but unless there is a bug in the JVM it can't do more.

        Thomas Steinbach added a comment -

        Bug is obsolete. No problems since longer time.

        Ticket could be closed.


          People

          • Assignee:
            Thomas Mortagne
            Reporter:
            Thomas Steinbach
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:
              Date of First Response: