XWiki Rendering
  1. XWiki Rendering
  2. XRENDERING-133

AbstractBlock#getChildrenByType does not take into account provided "recurse" parameter

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Blocker Blocker
    • Resolution: Fixed
    • Affects Version/s: 3.0 M3
    • Fix Version/s: 3.1.1, 3.2 M3
    • Component/s: API
    • Labels:
      None
    • Similar issues:
      XRENDERING-355plain/1.0 renderer should take into account plain/1.0 raw blocks
      XRENDERING-333Missing @Default annotation in Listener#endList for parameters
      XRENDERING-161Rendering Blocks are taking a lot more space than they should in memory
      XRENDERING-305xwiki/1.0 syntax module does not provide any StreamParser
      XRENDERING-214Add Table Block Constructors that take no extra parameters for consistency with other Blocks and simplicity
      XRENDERING-120xwiki/1.0 to xwiki/2.0 converter should change anchor and query string order
      XRENDERING-155It's not possible to set a custom "class" parameter for a freestanding link
      XRENDERING-252Velocity should be configured to use SLF4J logger
      XRENDERING-216Allow newline before macro parameters
      XRENDERING-130Provide rendering.version property

      Description

      Made a mistake when refactored it to use Block#getBlocks.

        Activity

        There are no comments yet on this issue.

          People

          • Assignee:
            Thomas Mortagne
            Reporter:
            Thomas Mortagne
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: