XWiki Platform
  1. XWiki Platform
  2. XWIKI-1044

Refreshing cached documents affects only the current request

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 1.0 B5
    • Fix Version/s: 1.2 RC1
    • Component/s: {Unused} Core
    • Labels:
      None
    • Similar issues:

      Description

      If I setup a cache for a document, for subsequent requests I get the version stored in the cache. I can override this by ading the "refresh=1" query parameter, but this does not refresh the cache, only returns the refreshed document.

        Activity

        Sergiu Dumitriu added a comment -

        The problem is that each document is cached using a key that contains the query string, so a query containing refresh=1 will not affect a document without that parameter. The solution is to ignore this param when computing the cache key.

        Sergiu Dumitriu added a comment -

        Fixed in rev. 6029

        When using ?refresh=1, only the document in the current language and with the current query string, except the refresh part, is refreshed. The content in other languages or other query strings remain cached.


          People

          • Assignee:
            Sergiu Dumitriu
            Reporter:
            Sergiu Dumitriu
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: