Uploaded image for project: 'XWiki Platform'
  1. XWiki Platform
  2. XWIKI-14966

If the extension has a different recommended version ask the user

    Details

    • Type: Improvement
    • Status: Open
    • Priority: Major
    • Resolution: Unresolved
    • Affects Version/s: 9.11.1
    • Fix Version/s: None
    • Component/s: Extension
    • Labels:
      None
    • Difficulty:
      Unknown
    • Similar issues:

      Description

      Since 9.6 we have the concept of recommended extensions versions and a default setup for commons/rendering/platform extensions. They are currently used in the upgrade manager and when selecting an extension dependency during install.

      It's would be quite complex to modify the search based on this configuration without degrading the performances but there is other things we can try.

      When a user try to install extension in version "10.5", the idea is to show some popup indicating that a different version ("9.10") is recommended and it would be better to install this one and give 3 choices ("Install 9.10", "Install 10.5", "Cancel").

        Attachments

          Activity

            People

            • Assignee:
              Unassigned
              Reporter:
              tmortagne Thomas Mortagne
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Date of First Response: