Uploaded image for project: 'XWiki Platform'
  1. XWiki Platform
  2. XWIKI-15628

Extensions need page refresh since there is an error in UI

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Invalid
    • Affects Version/s: 10.7
    • Fix Version/s: None
    • Component/s: Extension
    • Labels:
    • Environment:
      Ubuntu 16.04, XWiki 10.7
    • Difficulty:
      Unknown
    • Similar issues:

      Description

      I have XWiki 10.7 stable version installed on Ubuntu 16.04. I am always getting errors on XWiki UI while working with extensions installing/removing or importing/removing new components. When removing a new component I get this error:

      "Failed: Server not responding"

      When adding new component I get the following message:

      "An error occured while uploading <package name>"

      After I do page refresh the process seems to continue and components have been uploaded or removed properly. Logs do not show any meaningful info and this error seems to be only UI related but its frustrating since I need to refresh the page. I suspect this is related to reverse proxy nginx setup over https. I have tried same setup and it works fine over http, but https fails with those issues. I am attaching the nginx config for your reference.

      For you note I have also followed the settings at https://www.xwiki.org/xwiki/bin/view/Documentation/AdminGuide/Configuration/ and setup reverse proxy setup in XWiki but that did not help either.

        Attachments

          Activity

            People

            • Assignee:
              tmortagne Thomas Mortagne
              Reporter:
              vkrivenko Vitaly Krivenko
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:
                Date of First Response: