Uploaded image for project: 'XWiki Platform'
  1. XWiki Platform
  2. XWIKI-17327

Message Sender Macro breaks the page layout if a message is sent right after the page is saved when in-place editing

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 12.3-rc-1
    • Fix Version/s: 12.4
    • Component/s: None
    • Labels:
    • Environment:
      Windows 10 Pro 64 bit, Chrome 81, using a local instance XWiki 12.3 on Oracle 19c, Tomcat 9.0.31
    • Difficulty:
      Unknown
    • Documentation:
      N/A
    • Documentation in Release Notes:
      N/A
    • Similar issues:

      Description

      STEPS TO REPRODUCE

      1. Login with Admin and enable Message Stream from Administer Wiki > Other > Message Stream
      2. Edit in-place a page
      3. Click on Insert > Other Macros
      4. Search for Message Sender and click Select
      5. Click Submit
      6. Click Save & View
      7. Insert a message
      8. Click 'Share'

      EXPECTED RESULTS

      The message is sent properly.

      ACTUAL RESULTS

      The page gets broken, the Panels, Menus, Navigation Bar are not displayed anymore (see screenshot).

      However, if the page is refreshed first right after save (before any message is sent), the issue does not occur.
      Also, the issue doesn't reproduce if the macro is added in WYSIWYG mode.

        Attachments

          Activity

            People

            • Assignee:
              mflorea Marius Dumitru Florea
              Reporter:
              iandriuta Ilie Andriuta
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: