Uploaded image for project: 'XWiki Platform'
  1. XWiki Platform
  2. XWIKI-17915

Message stream messages are not displayed correctly in the rss feeds

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 11.10.10, 12.8, 12.9-rc-1
    • Fix Version/s: 11.10.11, 12.6.5, 12.10
    • Component/s: Message Stream
    • Labels:
      None
    • Tests:
      Unit
    • Difficulty:
      Unknown
    • Documentation:
      N/A
    • Documentation in Release Notes:
      N/A
    • Pull Request Status:
      Pull Request accepted
    • Similar issues:

      Description

      The message stream messages displayed in the RSS feeds of the notifications and the activity stream are not well displayed.

      The title is not defined, and the rendering depends of the rss client, some will display a default "no title", other will use the first line of the entry content.

      And the content looks like:

      MessageStream: [publicMessage] cd94f7c8-af2b-4c78-92e9-34ca168fb125 .
      
      edited by Administrator.2020/10/08 09:28
      Changes: ${newdoc.version}

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                mleduc Manuel Leduc
                Reporter:
                mleduc Manuel Leduc
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Date of First Response: