XWiki Platform
  1. XWiki Platform
  2. XWIKI-6199

When documents containing attachments were imported, XWikiAttachmentArchive.getVersions() throws an NPE if there is only one version.

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 3.0
    • Fix Version/s: 5.2-rc-1
    • Component/s: Storage
    • Labels:
    • Difficulty:
      Unknown
    • Documentation:
      N/A
    • Documentation in Release Notes:
      N/A
    • Similar issues:
      XWIKI-5098com.xpn.xwiki.api.Document.getPreviousVersion() throws NPE if current version is the first one
      XWIKI-1976Importing attachments will increase the attachment version
      XWIKI-10017Only lastest version of the attachment is imported in some versions of Confluence
      XWIKI-7754"Page from Office" does not import images from Word documents when Filesystem attachments are used.
      XWIKI-9807Confluence import fails for attachments with several versions
      XWIKI-4937Importing a new document with 'add new version to existing history' loses first version of the document
      XWIKI-1808Import document containing no "version" element will corrupt the document.
      XWIKI-932NPE during import on some documents
      XWIKI-3574Images from previous documents appear in the "Attachments" tab when import Word document via 'Import office document'
      XWIKI-7753Newer versions of (doc, docx) attachments are not indexed by Lucene

      Description

      to repeat:

      {{groovy}}
      xwiki.getDocument('Sandbox.WebHome').getDocument().getAttachmentList().get(0).loadArchive(xcontext.getContext()).getVersions();
      {{/groovy}}
      

        Issue Links

          Activity

          Eduard Moraru added a comment -

          Reproduces on 5.0-SNAPSHOT.

          Here's the stacktrace:

          Failed to execute the [groovy] macro
          
          org.xwiki.rendering.macro.MacroExecutionException: Failed to evaluate Script Macro for content [xwiki.getDocument('WorkspaceManager.Install').getDocument().getAttachmentList().get(0).loadArchive(xcontext.getContext()).getVersions();]
          	at org.xwiki.rendering.macro.script.AbstractJSR223ScriptMacro.evaluateBlock(AbstractJSR223ScriptMacro.java:178)
          	at org.xwiki.rendering.macro.script.AbstractJSR223ScriptMacro.evaluateBlock(AbstractJSR223ScriptMacro.java:53)
          	at org.xwiki.rendering.macro.script.AbstractScriptMacro.execute(AbstractScriptMacro.java:198)
          	at org.xwiki.rendering.macro.script.AbstractScriptMacro.execute(AbstractScriptMacro.java:59)
          	at org.xwiki.rendering.internal.transformation.macro.MacroTransformation.transformOnce(MacroTransformation.java:185)
          	at org.xwiki.rendering.internal.transformation.macro.MacroTransformation.transform(MacroTransformation.java:132)
          	at org.xwiki.rendering.internal.transformation.DefaultTransformationManager.performTransformations(DefaultTransformationManager.java:87)
          	at org.xwiki.display.internal.DocumentContentDisplayer.display(DocumentContentDisplayer.java:250)
          	at org.xwiki.display.internal.DocumentContentDisplayer.display(DocumentContentDisplayer.java:124)
          	at org.xwiki.display.internal.DocumentContentDisplayer.display(DocumentContentDisplayer.java:54)
          	at org.xwiki.display.internal.DefaultDocumentDisplayer.display(DefaultDocumentDisplayer.java:80)
          	at org.xwiki.display.internal.DefaultDocumentDisplayer.display(DefaultDocumentDisplayer.java:38)
          	at org.xwiki.sheet.internal.SheetDocumentDisplayer.display(SheetDocumentDisplayer.java:113)
          	at org.xwiki.sheet.internal.SheetDocumentDisplayer.display(SheetDocumentDisplayer.java:50)
          	at org.xwiki.display.internal.ConfiguredDocumentDisplayer.display(ConfiguredDocumentDisplayer.java:67)
          	at org.xwiki.display.internal.ConfiguredDocumentDisplayer.display(ConfiguredDocumentDisplayer.java:41)
          	at com.xpn.xwiki.doc.XWikiDocument.getRenderedContent(XWikiDocument.java:920)
          	at com.xpn.xwiki.doc.XWikiDocument.getRenderedContent(XWikiDocument.java:899)
          	at com.xpn.xwiki.doc.XWikiDocument.getRenderedContent(XWikiDocument.java:930)
          	at com.xpn.xwiki.api.Document.getRenderedContent(Document.java:603)
          	at sun.reflect.GeneratedMethodAccessor344.invoke(Unknown Source)
          	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
          	at java.lang.reflect.Method.invoke(Method.java:601)
          	at org.apache.velocity.util.introspection.UberspectImpl$VelMethodImpl.doInvoke(UberspectImpl.java:395)
          	at org.apache.velocity.util.introspection.UberspectImpl$VelMethodImpl.invoke(UberspectImpl.java:384)
          	at org.apache.velocity.runtime.parser.node.ASTMethod.execute(ASTMethod.java:173)
          	at org.apache.velocity.runtime.parser.node.ASTReference.execute(ASTReference.java:280)
          	at org.apache.velocity.runtime.parser.node.ASTReference.value(ASTReference.java:567)
          	at org.apache.velocity.runtime.parser.node.ASTExpression.value(ASTExpression.java:71)
          	at org.apache.velocity.runtime.parser.node.ASTSetDirective.render(ASTSetDirective.java:142)
          	at org.apache.velocity.runtime.parser.node.ASTBlock.render(ASTBlock.java:72)
          	at org.apache.velocity.runtime.parser.node.SimpleNode.render(SimpleNode.java:342)
          	at org.apache.velocity.runtime.parser.node.ASTIfStatement.render(ASTIfStatement.java:106)
          	at org.apache.velocity.runtime.parser.node.SimpleNode.render(SimpleNode.java:342)
          	at org.xwiki.velocity.internal.DefaultVelocityEngine.evaluate(DefaultVelocityEngine.java:228)
          	at org.xwiki.velocity.internal.DefaultVelocityEngine.evaluate(DefaultVelocityEngine.java:187)
          	at com.xpn.xwiki.render.XWikiVelocityRenderer.evaluate(XWikiVelocityRenderer.java:105)
          	at com.xpn.xwiki.internal.template.DefaultPrivilegedTemplateRenderer.evaluate(DefaultPrivilegedTemplateRenderer.java:125)
          	at com.xpn.xwiki.internal.template.DefaultPrivilegedTemplateRenderer.evaluateTemplate(DefaultPrivilegedTemplateRenderer.java:75)
          	at com.xpn.xwiki.XWiki.evaluateTemplate(XWiki.java:1787)
          	at com.xpn.xwiki.XWiki.parseTemplate(XWiki.java:1727)
          	at com.xpn.xwiki.api.XWiki.parseTemplate(XWiki.java:853)
          	at sun.reflect.GeneratedMethodAccessor192.invoke(Unknown Source)
          	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
          	at java.lang.reflect.Method.invoke(Method.java:601)
          	at org.apache.velocity.util.introspection.UberspectImpl$VelMethodImpl.doInvoke(UberspectImpl.java:395)
          	at org.apache.velocity.util.introspection.UberspectImpl$VelMethodImpl.invoke(UberspectImpl.java:384)
          	at org.apache.velocity.runtime.parser.node.ASTMethod.execute(ASTMethod.java:173)
          	at org.apache.velocity.runtime.parser.node.ASTReference.execute(ASTReference.java:280)
          	at org.apache.velocity.runtime.parser.node.ASTReference.render(ASTReference.java:369)
          	at org.apache.velocity.runtime.parser.node.ASTBlock.render(ASTBlock.java:72)
          	at org.apache.velocity.runtime.directive.VelocimacroProxy.render(VelocimacroProxy.java:216)
          	at org.apache.velocity.runtime.directive.RuntimeMacro.render(RuntimeMacro.java:311)
          	at org.apache.velocity.runtime.directive.RuntimeMacro.render(RuntimeMacro.java:230)
          	at org.apache.velocity.runtime.parser.node.ASTDirective.render(ASTDirective.java:207)
          	at org.apache.velocity.runtime.parser.node.SimpleNode.render(SimpleNode.java:342)
          	at org.xwiki.velocity.internal.DefaultVelocityEngine.evaluate(DefaultVelocityEngine.java:228)
          	at org.xwiki.velocity.internal.DefaultVelocityEngine.evaluate(DefaultVelocityEngine.java:187)
          	at com.xpn.xwiki.render.XWikiVelocityRenderer.evaluate(XWikiVelocityRenderer.java:105)
          	at com.xpn.xwiki.internal.template.DefaultPrivilegedTemplateRenderer.evaluate(DefaultPrivilegedTemplateRenderer.java:125)
          	at com.xpn.xwiki.internal.template.DefaultPrivilegedTemplateRenderer.evaluateTemplate(DefaultPrivilegedTemplateRenderer.java:75)
          	at com.xpn.xwiki.XWiki.evaluateTemplate(XWiki.java:1787)
          	at com.xpn.xwiki.web.Utils.parseTemplate(Utils.java:151)
          	at com.xpn.xwiki.web.XWikiAction.execute(XWikiAction.java:241)
          	at com.xpn.xwiki.web.XWikiAction.execute(XWikiAction.java:116)
          	at org.apache.struts.action.RequestProcessor.processActionPerform(RequestProcessor.java:431)
          	at org.apache.struts.action.RequestProcessor.process(RequestProcessor.java:236)
          	at org.apache.struts.action.ActionServlet.process(ActionServlet.java:1196)
          	at org.apache.struts.action.ActionServlet.doPost(ActionServlet.java:432)
          	at javax.servlet.http.HttpServlet.service(HttpServlet.java:727)
          	at javax.servlet.http.HttpServlet.service(HttpServlet.java:820)
          	at org.eclipse.jetty.servlet.ServletHolder.handle(ServletHolder.java:538)
          	at org.eclipse.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1352)
          	at com.xpn.xwiki.web.ActionFilter.doFilter(ActionFilter.java:120)
          	at org.eclipse.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1323)
          	at org.xwiki.wysiwyg.server.filter.ConversionFilter.doFilter(ConversionFilter.java:144)
          	at org.eclipse.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1323)
          	at org.xwiki.container.servlet.filters.internal.SavedRequestRestorerFilter.doFilter(SavedRequestRestorerFilter.java:208)
          	at org.eclipse.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1323)
          	at org.xwiki.container.servlet.filters.internal.SetCharacterEncodingFilter.doFilter(SetCharacterEncodingFilter.java:111)
          	at org.eclipse.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1323)
          	at org.eclipse.jetty.servlet.ServletHandler.doHandle(ServletHandler.java:476)
          	at org.eclipse.jetty.server.handler.ScopedHandler.handle(ScopedHandler.java:119)
          	at org.eclipse.jetty.security.SecurityHandler.handle(SecurityHandler.java:517)
          	at org.eclipse.jetty.server.session.SessionHandler.doHandle(SessionHandler.java:225)
          	at org.eclipse.jetty.server.handler.ContextHandler.doHandle(ContextHandler.java:937)
          	at org.eclipse.jetty.servlet.ServletHandler.doScope(ServletHandler.java:406)
          	at org.eclipse.jetty.server.session.SessionHandler.doScope(SessionHandler.java:183)
          	at org.eclipse.jetty.server.handler.ContextHandler.doScope(ContextHandler.java:871)
          	at org.eclipse.jetty.server.handler.ScopedHandler.handle(ScopedHandler.java:117)
          	at org.eclipse.jetty.server.Dispatcher.forward(Dispatcher.java:284)
          	at org.eclipse.jetty.server.Dispatcher.forward(Dispatcher.java:115)
          	at com.xpn.xwiki.web.ActionFilter.doFilter(ActionFilter.java:110)
          	at org.eclipse.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1323)
          	at org.xwiki.wysiwyg.server.filter.ConversionFilter.doFilter(ConversionFilter.java:144)
          	at org.eclipse.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1323)
          	at com.xpn.xwiki.plugin.webdav.XWikiDavFilter.doFilter(XWikiDavFilter.java:66)
          	at org.eclipse.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1323)
          	at org.xwiki.container.servlet.filters.internal.SavedRequestRestorerFilter.doFilter(SavedRequestRestorerFilter.java:208)
          	at org.eclipse.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1323)
          	at org.xwiki.container.servlet.filters.internal.SetCharacterEncodingFilter.doFilter(SetCharacterEncodingFilter.java:111)
          	at org.eclipse.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1323)
          	at org.eclipse.jetty.servlet.ServletHandler.doHandle(ServletHandler.java:476)
          	at org.eclipse.jetty.server.handler.ScopedHandler.handle(ScopedHandler.java:119)
          	at org.eclipse.jetty.security.SecurityHandler.handle(SecurityHandler.java:517)
          	at org.eclipse.jetty.server.session.SessionHandler.doHandle(SessionHandler.java:225)
          	at org.eclipse.jetty.server.handler.ContextHandler.doHandle(ContextHandler.java:937)
          	at org.eclipse.jetty.servlet.ServletHandler.doScope(ServletHandler.java:406)
          	at org.eclipse.jetty.server.session.SessionHandler.doScope(SessionHandler.java:183)
          	at org.eclipse.jetty.server.handler.ContextHandler.doScope(ContextHandler.java:871)
          	at org.eclipse.jetty.server.handler.ScopedHandler.handle(ScopedHandler.java:117)
          	at org.eclipse.jetty.server.handler.ContextHandlerCollection.handle(ContextHandlerCollection.java:247)
          	at org.eclipse.jetty.server.handler.HandlerCollection.handle(HandlerCollection.java:149)
          	at org.eclipse.jetty.server.handler.HandlerWrapper.handle(HandlerWrapper.java:110)
          	at org.eclipse.jetty.server.Server.handle(Server.java:346)
          	at org.eclipse.jetty.server.HttpConnection.handleRequest(HttpConnection.java:589)
          	at org.eclipse.jetty.server.HttpConnection$RequestHandler.content(HttpConnection.java:1065)
          	at org.eclipse.jetty.http.HttpParser.parseNext(HttpParser.java:823)
          	at org.eclipse.jetty.http.HttpParser.parseAvailable(HttpParser.java:220)
          	at org.eclipse.jetty.server.HttpConnection.handle(HttpConnection.java:411)
          	at org.eclipse.jetty.io.nio.SelectChannelEndPoint.handle(SelectChannelEndPoint.java:535)
          	at org.eclipse.jetty.io.nio.SelectChannelEndPoint$1.run(SelectChannelEndPoint.java:40)
          	at org.eclipse.jetty.util.thread.QueuedThreadPool$3.run(QueuedThreadPool.java:529)
          	at java.lang.Thread.run(Thread.java:722)
          Caused by: javax.script.ScriptException: javax.script.ScriptException: java.lang.NullPointerException
          	at org.codehaus.groovy.jsr223.GroovyScriptEngineImpl.eval(GroovyScriptEngineImpl.java:152)
          	at org.xwiki.rendering.macro.script.AbstractJSR223ScriptMacro.eval(AbstractJSR223ScriptMacro.java:279)
          	at org.xwiki.rendering.macro.script.AbstractJSR223ScriptMacro.evaluateBlock(AbstractJSR223ScriptMacro.java:213)
          	at org.xwiki.rendering.macro.script.AbstractJSR223ScriptMacro.evaluateBlock(AbstractJSR223ScriptMacro.java:173)
          	... 123 more
          Caused by: javax.script.ScriptException: java.lang.NullPointerException
          	at org.codehaus.groovy.jsr223.GroovyScriptEngineImpl.eval(GroovyScriptEngineImpl.java:349)
          	at org.codehaus.groovy.jsr223.GroovyScriptEngineImpl.eval(GroovyScriptEngineImpl.java:146)
          	... 126 more
          Caused by: java.lang.NullPointerException
          	at com.xpn.xwiki.doc.XWikiAttachmentArchive.getVersions(XWikiAttachmentArchive.java:223)
          	at com.xpn.xwiki.doc.XWikiAttachmentArchive$getVersions.call(Unknown Source)
          	at org.codehaus.groovy.runtime.callsite.CallSiteArray.defaultCall(CallSiteArray.java:45)
          	at org.codehaus.groovy.runtime.callsite.AbstractCallSite.call(AbstractCallSite.java:108)
          	at org.codehaus.groovy.runtime.callsite.AbstractCallSite.call(AbstractCallSite.java:112)
          	at Script2.run(Script2.groovy:1)
          	at org.codehaus.groovy.jsr223.GroovyScriptEngineImpl.eval(GroovyScriptEngineImpl.java:346)
          	... 127 more
          

            People

            • Assignee:
              Thomas Mortagne
              Reporter:
              CalebJamesDeLisle
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:
                Date of First Response: