Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 3.0
    • Fix Version/s: 3.3-milestone-1
    • Component/s: None
    • Labels:
      None
    • Environment:
      Ubuntu Server 10.04 LTS (Kernel 2.6.32-311-ec2 amd64), Apache Tomcat/6.0.24, JVM 1.6.0_20-b20 (Sun Microsystems Inc)
    • keywords:
      attachments filesystem
    • Difficulty:
      Unknown
    • Similar issues:

      Description

      Hi! First of all, the new XWiki 3.0 is amazing! Filesystem Attachment storage rules!!

      Well, this is my problem: I uploaded a ~180KB attachment image file and put it into a blog post, but all the HTTP requests to this file gets stuck! The request starts but it doesn't finish! I tried using wget, but it got stuck waiting for the response. It seems that it worked at the beginning, because my Browser cached the image.

      As a result, I have more than 50 stuck threads (using Tomcat Manager) serving this file, all of them showing 0B received and 0B sent.

      FYI, I'm using the new Filesystem Attachment Storage and this page was exported from a "test" Wiki and imported into our "production" Wiki.

      Thanks everybody and keep with the good work!!

      Regards,

      Felipe Giotto.

        Attachments

          Activity

            People

            • Assignee:
              calebjamesdelisle CalebJamesDeLisle
              Reporter:
              felipegiotto Felipe Giotto
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:
                Date of First Response: