XWiki Platform
  1. XWiki Platform
  2. XWIKI-7683

xwiki-platform-tool-functional-test-lifecycle makes a pain to release platform

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Blocker Blocker
    • Resolution: Fixed
    • Affects Version/s: 4.0-milestone-1
    • Fix Version/s: 4.0
    • Labels:
      None
    • Difficulty:
      Unknown
    • Similar issues:
      XWIKI-7583Export XAR fails in a minimal wiki setup
      XWIKI-5270Prevent backward compatibility regressions in platform/core
      XWIKI-54Make the Build platform success all tests
      XWIKI-7023Add Workspace Manager to XWiki Platform
      XWIKI-3833Upgrade to latest released Plexus
      XWIKI-7299Upgrade platform to use SmartGWT 3.0
      XWIKI-1372Make XWiki platform GWT-ready
      XWIKI-7861WYSIWYG Editor WAR distribution fails to release.
      XWIKI-10251Build of xwiki-platform breaks with wrong locale
      XWIKI-8013ApplicationReadyEvent event is sent before XWikiStubContextProvider is initialized

      Description

      Because maven does not support building and using an extension in the same reactor.

      That's why we moved the xar handler and plugin to commons by the way.

        Activity

        Vincent Massol added a comment -

        The problem is that with Maven 3 you cannot build a maven extension and use it in the same reactor, see http://jira.codehaus.org/browse/MNG-1911

        Vincent Massol added a comment -

        Fixed by removing the "functional-test" lifecycle for now till the Maven issue if fixed. That's a pain but that's life...


          People

          • Assignee:
            Vincent Massol
            Reporter:
            Thomas Mortagne
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:
              Date of First Response: