Uploaded image for project: 'XWiki Platform'
  1. XWiki Platform
  2. XWIKI-9920

Extension Manager add extension search should suggest only compatible versions

    Details

    • Type: Improvement
    • Status: Open
    • Priority: Major
    • Resolution: Unresolved
    • Affects Version/s: 5.2.3
    • Fix Version/s: None
    • Component/s: Extension
    • Labels:
      None
    • Difficulty:
      Unknown
    • Similar issues:

      Description

      Steps to reproduce:

      1. Login as an Admin in XWiki 5.2.3
      2. In the Applications panel on the right, click on "More applications" and then on "Install new applications"
      3. Type an extension name that you know has a stable 5.2.3 version; for ex. use one of these: FAQ Application, JIRA Macro or IRC Bot Application
      4. Hit Enter

      The suggested version will be 5.3 and you'll get a similar error to this one:

      Dependency [org.xwiki.platform:xwiki-platform-rendering-wikimacro-store-5.3] is not compatible with core extension [org.xwiki.platform:xwiki-platform-rendering-wikimacro-store-5.2.3]

      if you try to install that version.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                Unassigned
                Reporter:
                msmeria Manuel Smeria
              • Votes:
                7 Vote for this issue
                Watchers:
                6 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Date of First Response: