{RETIRED} XWiki Workspaces
  1. {RETIRED} XWiki Workspaces
  2. XWS-192

activity_builder field in XWSApps.Blog, Files, Stream, Photos not configured correctly

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Duplicate
    • Affects Version/s: 1.2 M1
    • Fix Version/s: None
    • Component/s: Workspace Applications
    • Labels:
      None
    • Similar issues:
      XWS-84Missing right-panel links to delete files and photos
      XWS-145Add a field to give a title to an image in the photo application
      XWS-190On dashboards, the links to photo gallery images lead to an empty page
      XWS-217Activity Stream not displaying correctly
      XWS-188When we attach a new image in an existing gallery, in the activity stream the message "created" when it should be "updated"
      XWS-168Activity event displayed on space dashboard when deleting a photo gallery present a link to the deleted gallery
      XWS-17JavaScript error when uploading photos
      XWS-166When deleting a photo gallery, activity events are generated for each deleted picture
      XWS-55In a photo galerie the "Uploaded on" sometimes overlap its picture box
      XWS-98Usability Improvements for the Files Application

      Description

      Upon implementing my own activitystream event type for the Blog application, I found that BlogApplicationActivityBuilder was not being called when it should have been. Instead, ApplicationDefaultActivityBuilder was being called. It turns out that the activity_builder field of the XWiki.XWSApplicationClass object in the XWSApp.BlogApp application document had been entered incorrectly.

      Before I updated it, it was: com.xpn.xwiki.plugin.workspacesmanager.activities.BlogApplicationActivityBuilder

      After I changed it to: com.xpn.xwiki.plugin.workspacesmanager.apps.activities.builders.BlogApplicationActivityBuilder, the correct class was instantiated.

      The same error was found in FilesApp, PhotosApp, and StreamApp.

        Activity

        Jerome Velociter added a comment -

        Hi Dan,

        Thanks for the report. I have already fixed this, which was the cause of issues XWS-190 & XWS-183. I will release XWS 1.1.1 very soon, including this fixes. (They are also fixed in the forthcoming 1.2 M2)

        Thanks again,
        Jerome.


          People

          • Assignee:
            Unassigned
            Reporter:
            Dan Svoboda
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:
              Date of First Response: