XWiki Platform
  1. XWiki Platform
  2. XWIKI-7439

Category becomes invisible when adding a subcategory with the same name as parent category

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 3.4
    • Fix Version/s: 3.5-milestone-1
    • Component/s: Blog
    • Labels:
      None
    • Difficulty:
      Unknown
    • Similar issues:
      XWIKI-10077Blog categories counter doesn't properly work when adding a post to a subcategory
      XWIKI-9252Unable to organize a blog's subcategory
      XWIKI-8487Blog categories aren't added in the right place on IE9
      XWIKI-11241Wiki Syntax in categories breaks the category management
      XWIKI-9740Categories field updates (check / uncheck) are not taken into account after adding a new category when editing a blog post
      XWIKI-9030Unable to add a category or a subcategory when editing a blog post
      XWIKI-6346Cannot add a category that has the same name as a blog post
      XWIKI-1613List of category is not updated in Blog part (could be linked to DBList cache)
      XWIKI-11562Add ability to contribute new Admin categories through ConfigurableClass xobjects
      XWIKI-354Support deeper hierarchical paths/names for documents

      Description

      Steps to reproduce:

      • login
      • go to Blog Space
      • on the Blog Categories Panel from left, click "Edit Categories"
      • add a subcategory to News called News. Basically a category with the same name as its parent name

      You will see that News category (parent) will disappear along with its subcategory.

      This happens on Chrome 16 and Firefox 9.0.1. Does not happen on IE8 and IE9

      We should have a Selenium 2 test for this after it is fixed

        Issue Links

          Activity

          Sergiu Dumitriu added a comment -

          Fixed in 10655f5

          Marius Dumitru Florea added a comment -

          The root cause is the same as for XWIKI-7268: XWikiDocument#readFromTemplate checks for empty content, and the content of the category page is empty since we introduced the new sheet system, which doesn't rely on the include macro any more.


            People

            • Assignee:
              Sergiu Dumitriu
              Reporter:
              Sorin Burjan
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:
                Date of First Response: