Uploaded image for project: 'CKEditor Integration'
  1. CKEditor Integration
  2. CKEDITOR-394

Syntax Conversion Fails Without Error (and Messes up Page)

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Critical
    • Resolution: Fixed
    • Affects Version/s: 1.53.1
    • Fix Version/s: 1.53.2
    • Component/s: None
    • Labels:
      None
    • Tests:
      Integration
    • Difficulty:
      Unknown
    • Documentation:
      N/A
    • Documentation in Release Notes:
      N/A
    • Similar issues:

      Description

      Experienced with latest LTS release:

      1. Changing the Syntax in WYSIWYG edit mode (tested with changing from XWiki 2.1 to  Markdown 1.2) asks if the page syntax shall be converted.
      2. After confirmation, the page is still displayed in the WYSIWYG editor just fine.
      3. When saving, the page looks all messed up - reason is that the page syntax was NOT actually converted, contrary to the information from the popup.
      4. Changing the syntax back to XWiki 2.1 with additional syntax transformation then really messes up the page this time, as then it's actually converted, but (logically) interpreting the XWiki 2.1 as Markdown 1.2, and escaping everything...

      You can see a screen recording of steps 1-3 in the attachment.

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              mflorea Marius Dumitru Florea
              Reporter:
              GOhrner Gunter Ohrner
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:
                Date of First Response: