Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 1.1
    • Labels:
      None
    • Difficulty:
      Unknown
    • Similar issues:

      Description

      Steps to reproduce

      • Install application version 1.1-SNAPSHOT on a local XWiki 11.5 via the XWiki Extension Manager (after making sure that the previous local installations were cleaned up from the permanent directory extensions repository).
      • Go to a point entry listed on the home page of the app, for instance "Maps/Demo/Mountains/Broad Peak"

      Result

      The map on the point page does not show up and the JavaScript console displays the following error:

      The script from “http://ako:8090/xwiki/webjars/wiki%3Aabraca/leaflet/1.5.1/1.5.1/dist/leaflet.js?r=1” was loaded even though its MIME type (“text/html”) is not a valid JavaScript MIME type.
      Broad Peak
      Loading failed for the <script> with source “http://ako:8090/xwiki/webjars/wiki%3Aabraca/leaflet/1.5.1/1.5.1/dist/leaflet.js?r=1”. Broad Peak:1:1
      Error: Script error for "leaflet"
      http://requirejs.org/docs/errors.html#scripterror
      

      When removing the version number "1.5.1" from the JavaScript extension in LeafletUtils (code below), the error is not raised any more, however the map does not load correctly, possibly a CSS issue.

      'leaflet': ['$services.webjars.url("leaflet", "1.5.1/dist/leaflet.js")'

      Map:

       

        Attachments

          Activity

            People

            • Assignee:
              GinPachi Fawad Ali
              Reporter:
              slauriere slauriere
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:
                Date of First Response: