Uploaded image for project: 'Map Macro'
  1. Map Macro
  2. MAP-15

When location is Non-ASCII Character, map is not loaded.

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 1.2.3
    • Fix Version/s: 1.2.4
    • Labels:
      None
    • Environment:
      XWiki 9.11 Community version, Linux
    • Difficulty:
      Easy
    • Documentation:
      N/A
    • Documentation in Release Notes:
      N/A
    • Similar issues:

      Description

      I found this problem, when I made my meeting on Meeting Application.

      If I specify location as Korean, Map is not loaded.
      and If I specify location as English, Map is loaded.

      Because Meeting Application uses Map macro, I checked and modified Map macro. And this problem is solved.

      I modified XWiki.WikiMacroClass of Map Macro.

      title="$!{escapetool.javascript($context.macro.params.location)}"
      

      ==>

      title="$!{xcontent.macro.params.location}"
      

      This is a problem that user can fix by himself, but I hope the fix for this problem is reflected in the project.

        Attachments

          Activity

            People

            • Assignee:
              acotiuga Alex Cotiugă
              Reporter:
              wizlong Ohyoung Kwon
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:
                Date of First Response: