Uploaded image for project: 'Markdown Syntax'
  1. Markdown Syntax
  2. MARKDOWN-56

CkEditor adds xwiki syntax macros to markdown documents leading to broken markdown rendering

    Details

    • Type: Bug
    • Status: Open
    • Priority: Blocker
    • Resolution: Unresolved
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: Markdown 1.2
    • Labels:
      None
    • Environment:
      XWiki 9.11.8 docker container
    • Difficulty:
      Unknown
    • Similar issues:

      Description

      Affected XWiki Version: 9.11.8 (was not selectable in the "affected version dropdown)

       

      I am using the ckeditor and markdown 1.2 as default syntax.

      In the editor i can add a infobox via the "style" dropdown from the ckeditor toolbar. It renders well in the editor but when i save the document the infobox is gone and only the content of the infobox is rendered as plain text.

      Furthermore i have a large markdown document i inserted into xwiki. Save and everything is fine. Reopen and adding an infobox srews up to whole document. Code boxes are cut in half, the whole document is messed up. And then it is not possible to repair it with the ckeditor as it is impossible to edit the source due to a javascript error as a result to a broken link.

       

      Maybe i am doing something wrong?

       

      Adding the infobox by hand with the macro-syntax info<content>/info works fine though.

        Attachments

          Activity

            People

            • Assignee:
              Unassigned
              Reporter:
              Jülke Gabriel Jülke
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated: