Uploaded image for project: 'OpenId Connect'
  1. OpenId Connect
  2. OIDC-74

Make the scope configurable in the authenticator

    Details

    • Type: New Feature
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 1.15.1
    • Fix Version/s: 1.16
    • Component/s: Authenticator
    • Labels:
      None
    • Difficulty:
      Easy
    • Documentation:
      N/A
    • Documentation in Release Notes:
      N/A
    • Similar issues:

      Description

      gitlab have a different understanding for the openid scope, however, currently the scope is hard coded, that will cause gitlab respond 'invalid scope'.

      make scope a config option, please.

       

        Attachments

          Activity

            People

            • Assignee:
              tmortagne Thomas Mortagne
              Reporter:
              Guogang Fan
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:
                Date of First Response: