Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 1.0.1
    • Fix Version/s: 1.0.2
    • Labels:
    • Environment:
      Windows 10 Pro 64 bit, Chrome v.63, Firefox v.57, IE v.11, Edge v.16 using a local instance XWiki 9.11 on PostgreSQL 10
    • Difficulty:
      Unknown
    • Similar issues:

      Description

      STEPS TO REPRODUCE:

      1. Login with Admin or with an user
      2. Set 'Display hidden pages' to 'YES' from Profile > Preferences > Display Preferences
      3. Click on 'Templates' page from Navigation panel or from Page Index (/xwiki/bin/view/Templates/)
      4. Observe the console

      EXPECTED RESULTS

      The 'Templates' page is displayed without any errors.

      ACTUAL RESULTS

      The 'Template' page opens, followed by an error in console, having the following stacktrace:

      2017-12-22 13:31:04,028 [http://localhost:8080/xwiki/bin/get/Templates/WebHome?outputSyntax=plain&sheet=XWiki.DocumentTree&root=space%3ATemplates&root=space%3ATemplates&data=children&id=%23] ERROR o.x.v.i.DefaultVelocityEngine  - Left side ($childNodeIds.size()) of '>=' operation has null value at 43:xwiki:XWiki.DocumentTree[line 144, column 29]

      The issue reproduces also on previous XWiki versions (tested down to 8.4.5).

        Attachments

          Activity

            People

            • Assignee:
              acotiuga Alex Cotiugă
              Reporter:
              iandriuta Ilie Andriuta
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:
                Date of First Response: