Uploaded image for project: 'Forum Application'
  1. Forum Application
  2. XAFORUM-251

Can't delete a forum from the Forums Webhome Livetable

    Details

    • Type: Bug
    • Status: Open
    • Priority: Major
    • Resolution: Unresolved
    • Affects Version/s: 2.2
    • Fix Version/s: None
    • Labels:
      None
    • Environment:
      IE 11, local instance 9.7 standard and MySQL
    • Similar issues:

      Description

      Steps to reproduce:

      1. Create a new forum as Admin or simple user
      2. As Admin go to the Forums WebHome http://localhost:8080/xwiki/bin/view/Forums/
      3. From the LiveTable click on Delete for the newly created forum
      4. Click on Yes

      Expected results: The forum is deleted.

      Actual results: The forum is not deleted and a message in red appears "The forum could not be deletedUnauthorized".
      In the Console I get:

      2017-09-28 16:10:03,164 [http://localhost:8080/xwiki/bin/get/ForumCode/Actions?outputSyntax=plain] WARN  o.x.c.i.DefaultCSRFToken       - CSRFToken: Secret token verification failed, token: "wQQETBRB96XmunFVQHyQtQ", stored token: "RKAZJjGxCEiwYYsF5Upv9g"
      

      NOTE: I can delete the forum as Admin only as a normal page: click on the Forum > More Actions > Delete > Affect children and Delete

        Attachments

          Activity

            People

            • Assignee:
              Unassigned
              Reporter:
              ganechitoaei Gabriela Anechitoaei
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Date of First Response: