Uploaded image for project: 'XWiki Commons'
  1. XWiki Commons
  2. XCOMMONS-1238

Bug in version constraint merge when one of the version is a strict version not matching the recommended version

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Blocker
    • Resolution: Fixed
    • Affects Version/s: 8.4.5
    • Fix Version/s: 9.7-rc-1, 8.4.6
    • Component/s: Extension
    • Labels:
      None
    • Tests:
      Unit
    • Documentation:
      N/A
    • Documentation in Release Notes:
      N/A
    • Similar issues:

      Description

      For example merging 1.0 and [2.0] version contains fail instead of giving 2.0 (if you have a dependency on 1.0 it's compatible with version 2.0).

        Attachments

          Activity

            People

            • Assignee:
              tmortagne Thomas Mortagne
              Reporter:
              tmortagne Thomas Mortagne
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:
                Date of First Response: