Uploaded image for project: 'XWiki Commons'
  1. XWiki Commons
  2. XCOMMONS-1265

Errors when upgrading from an older version of XWiki containing sub-wikis

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 8.4.5, 9.6
    • Fix Version/s: 9.8-rc-1, 8.4.6
    • Component/s: None
    • Labels:
      None
    • Environment:
      Windows 10 Pro 64 bit, Chrome v.60, Firefox v.54, IE v.11
    • Documentation:
      N/A
    • Documentation in Release Notes:
      N/A
    • Similar issues:

      Description

      Prerequisites: An instance of an older version of XWiki (e.g. v 8.4.5) containing at least one sub-wiki and a newer version (to which will be migrated - e.g. v 9.6) are available.

      STEPS TO REPRODUCE:

      1. Delete the "data" folder from the newer version
      2. Copy the "data" folder from the older version and paste it in the folder of the newer version
      3. Start XWiki
      4. Login as Admin
      5. Use the Distribution Wizard to complete the upgrade process
      6. Observe the install log

      EXPECTED RESULTS

      The upgrade to the newer XWiki version (e.g. v 9.6) is successfully completed without any errors.

      ACTUAL RESULTS

      When installing the standard flavor, some errors/warnings appear in the install log (screenshot attached), regardless of the configured database (HyperSQL, PostGreSQL, MySQL or Oracle).

        Attachments

          Activity

            People

            • Assignee:
              tmortagne Thomas Mortagne
              Reporter:
              iandriuta Ilie Andriuta
            • Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:
                Date of First Response: