Uploaded image for project: 'XWiki Commons'
  1. XWiki Commons
  2. XCOMMONS-193

Upgrade to Maven Enforcer plugin 1.1

    Details

    • Documentation:
      N/A
    • Documentation in Release Notes:
      N/A
    • Similar issues:

      Description

      Release Notes - Maven 2.x Enforcer Plugin - Version 1.1
      
      ** Bug
         * [MENFORCER-98] - requirePluginVersions rule is not compatible with maven 3.0-beta-1
         * [MENFORCER-114] - Typo in Require Plugin Versions Documentation
         * [MENFORCER-125] - requireProperty documentation's example for property.version uses wrong regex
      
      ** Improvement
         * [MENFORCER-118] - DependencyConvergence gets better if it doesn't fail on snapshots of same baseVersion
      
      ** New Feature
         * [MENFORCER-128] - Fail the build if a dependency is overwriten with an incompatible lower version (patch)
      

        Attachments

          Activity

            People

            • Assignee:
              vmassol Vincent Massol
              Reporter:
              vmassol Vincent Massol
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: