Uploaded image for project: 'XWiki Commons'
  1. XWiki Commons
  2. XCOMMONS-334

Validate versions for POM dependencies

    Details

    • Type: Improvement
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 4.4
    • Fix Version/s: 4.5-rc-1
    • Labels:
      None
    • Documentation:
      N/A
    • Documentation in Release Notes:
      N/A
    • Similar issues:

      Description

      I've lost more than 30 minutes during the last XWiki release because of dependencies having wrong versions so I got fed up. In order to improve our release speed we need to ensure we have valid POMs that won't generate a build issue during releases.

      Example of invalid dependency definition:

          <dependency>
            <groupId>org.xwiki.rendering</groupId>
            <artifactId>xwiki-rendering-macro-html</artifactId>
            <version>${commons.version}</version>
            <scope>runtime</scope>
          </dependency>
      

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                vmassol Vincent Massol
                Reporter:
                vmassol Vincent Massol
              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: