XWiki Enterprise
  1. XWiki Enterprise
  2. XE-1054

AS broken UI when it has to display a document created in the future

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 3.2, 3.3-milestone-1
    • Fix Version/s: 3.3-rc-1
    • Labels:
      None
    • Similar issues:

      Description

      This may seem odd, maybe doesn't even provide a real usecase, but I decided still to report it

      Steps to reproduce:

      • login and create a page (confirm it appears on the AS)
      • change the system date to a future date
      • create a page (confirm it appears on the AS)
      • set the date back to the original date

      The date is indented, but the future page is still displayed correctly in the AS

      Screenshot attached

        Issue Links

          Activity

          Sorin Burjan added a comment -

          It seems that if you delete the document (even as admin and remove it from recycle bin), the page still appears in AS. We should consider a fix because not everybody uses NTP, and users may have certain issues like these

          Sergiu Dumitriu added a comment -

          What do you propose? I can't think of any proper fix, other than limiting the events returned by the activity stream to "event.date <= NOW()", which would slow down the queries to fix a potential problem that won't affect a very big majority of users.

          Sorin Burjan added a comment -

          My only proposal is to only remove that indentation, because I don't see its purpose. I am not saying to limit the AS to display until current date.

          Sergiu Dumitriu added a comment -

          Ah, didn't see the indentation.

          Sergiu Dumitriu added a comment -

          Fixed in 4cc02f1


            People

            • Assignee:
              Sergiu Dumitriu
              Reporter:
              Sorin Burjan
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:
                Date of First Response: