{RETIRED} XWiki Enterprise
  1. {RETIRED} XWiki Enterprise
  2. XE-1255

Fresh install of 4.3@Debian 6 can't find hibernate.cfg.xml

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Blocker Blocker
    • Resolution: Fixed
    • Affects Version/s: 4.3
    • Fix Version/s: 4.3.1
    • Component/s: Debian packages
    • Labels:
      None
    • Environment:
      Debian GNU/Linux 6.0 x64, Apache Tomcat/6.0.35, PostgreSQL 8.4.13-0squeeze1
    • Documentation:
      N/A
    • Documentation in Release Notes:
      N/A
    • Similar issues:

      Description

      :to Hi, after a fresh install I got the following error:

      javax.servlet.ServletException: com.xpn.xwiki.XWikiException: Error number 3 in 0: Could not initialize main XWiki context
      Wrapped Exception: Error number 3202 in 3: Exception while reading document [xwiki:XWiki.TagClass]
      Wrapped Exception: Can't find [/WEB-INF/hibernate.cfg.xml] for hibernate configuration org.apache.struts.action.RequestProcessor.processException(RequestProcessor.java:535) ...

      The file exists and there is no problem with links - even this doesn't help, including a number of Tomcat restarts:
      /usr/lib/xwiki/WEB-INF# cp /etc/xwiki/hibernate.cfg.xml ./

      The hibernate.cfg.xml looks OK. I also reconfigured it according to the commented PostgreSQL configuration, which had different number of lines.

      See chmelab.net for details.

        Issue Links

          Activity

          Sergiu Dumitriu added a comment -

          As stated on http://markmail.org/thread/r7b7wnubq4bmcjyj the problem is that the file has wrong permissions, and a chmod (or chown) will solve the issue.

          If you fix this, you'll also run into XE-1254.

          Petr added a comment -

          Thank you, all fixed


            People

            • Assignee:
              Thomas Mortagne
              Reporter:
              Petr
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:
                Date of First Response: