Uploaded image for project: '{RETIRED} XWiki Enterprise'
  1. {RETIRED} XWiki Enterprise
  2. XE-1506

Make sure log4j 1.x and commons-logging are identified as core extensions

    Details

    • Type: Improvement
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 7.2
    • Fix Version/s: 7.3, 7.4-milestone-1
    • Component/s: Packaging
    • Labels:
      None
    • Documentation:
      N/A
    • Similar issues:

      Description

      The XE WAR embeds log4j-over-slf4j and jcl-over-slf4j to replace log4j 1.x and commons-logging but right now Extension Manager does not know that and can end up installing them as dependencies.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                tmortagne Thomas Mortagne
                Reporter:
                tmortagne Thomas Mortagne
              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: