Uploaded image for project: '{RETIRED} XWiki Enterprise'
  1. {RETIRED} XWiki Enterprise
  2. XE-356

Performance problem with many blog articles

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Critical
    • Resolution: Fixed
    • Affects Version/s: 1.7
    • Fix Version/s: 1.7.1
    • Labels:
      None
    • Environment:
      tomcat 5.5.16
      jdk 1.5.0_13
      Fedora 9
      Postgresql 8.3.4
    • keywords:
      cpu, dynamic, regex
    • Similar issues:

      Description

      My 1.6 Xwiki install has started eating all my CPU when I try to go to any "rendered page" like Blogs or What's New. Regular static pages work fine. Eventually, tomcat times out the connection to the rendered page. I upgraded to 1.7 but the behavior is still the same.

      Attached is the Xwiki.log, which doesn't seem to have much other than an NPE which I doubt is the cause. Also included is a thread dump in the catalina.out.

      This is an internal system so that there are no crawlers or the like in the environment. I never happens unless trying to run something dynamic like Blog.Macros.

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              sdumitriu Sergiu Dumitriu
              Reporter:
              dmangot Dave Mangot
              Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:
                Date of First Response: