Uploaded image for project: 'XWiki MS Office Integration'
  1. XWiki MS Office Integration
  2. XOFFICE-249

XWord installer for MS Office 2007 does not automatically install PIA dependency



    • Bug
    • Resolution: Unresolved
    • Major
    • None
    • None
    • XWord
    • None
    • xword, installation problem


      The following quoted from 'external bug report' here : http://xwiki.475771.n2.nabble.com/BUG-XWord-installer-for-MS-Office-2007-does-not-automatically-install-PIA-dependency-td5068886.html

      This bug should be registered here & addressed.

      After the installation, XWord tab does not appear. Having tried to enable the add-in manually I've received the following error: "Not loaded. A runtime error occurred during the loading of the COM Add-in."

      I have found similar issue for XWord 2003 in XWiki Jira: http://jira.xwiki.org/jira/browse/XOFFICE-160 it looks still unresolved.

      List of currently installed software on my PC is attached (InstalledSoftware.txt). One additional note is that I had MS Office 2003 Web Components installed on my first attempt. But then I've removed it and re-installed XWord once again with the same result.

      Having looked carefully once again on the installation procedure I've noticed a list of dependencies with PIA (Microsoft Office Primary Interoperability Assemblies) which was not in the list of installed software. So I have installed it manually, re-enabled XWord plug-in and the XWord tab has finally appeared.

      I believe this error might be due to PIA install pack structure specifics. It does not actually install the app - it only extracts another installer which should be run separately.

      Hope this info will help someone someday.


      Hi Roman,

      Thanks for this detailed install report.
      The assemblies that are a part of the PIAs have the same name regardless of
      the office version. You may have had the 2003 versions installed thus
      preventing the XOffice bootstrapper from installing the PIA. When installed
      by a bootstrapper inside an installer and not stand alone, PIA won't be
      listed as an separate application in Control Panel.
      Also, there seems to be an issue with the PIAs which are currently listed as
      unavailable for bootsrapping. This is the more probable cause of the issue.
      If this persists I will change the dependency download location from
      Microsoft sites to xwiki.org.

      Florin Ciubotaru




            florin_c Florin Ciubotaru
            stactrac Jim Jammeson
            0 Vote for this issue
            0 Start watching this issue