Uploaded image for project: 'XWiki Rendering'
  1. XWiki Rendering
  2. XRENDERING-199

Id Macro doesn`t work properly

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Won't Fix
    • Affects Version/s: 3.4, 4.0
    • Fix Version/s: None
    • Component/s: Macro - Id
    • Labels:
      None
    • Environment:
      testet on
      tomcat & mysql & linux
      and
      jetty & hsql & windows 7
    • keywords:
      id-macro, macro-id, macros, priority, rights, macro
    • Similar issues:

      Description

      On XWiki 3.4 + 4.0 the id-macro fails in many cases. I hope someone can reproduce the problem when using the following minimalistic code-snippet:

      id-macro example
      = FROM =
      == ID ==
      [[IDLink>>#idName]]
      
      = TO =
      == ID ==
      {{id name="idName"/}}
      

      On our instance the macro doesn`t work when creating a new page using the snippet above. But it does work when pasting the snippet for example to the end of "Sandbox.WebHome". But when copying the code of "Sandbox.WebHome" and creating a new Page based on that code the macro fails again.

      It doesn`t depend on users rights. The macro also fails when creating the new page as admin. Maybe it has something to do with priority and execution order of macros within one page?

        Attachments

          Activity

            People

            Assignee:
            tmortagne Thomas Mortagne
            Reporter:
            heinkunibert Hein Kunibert
            Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:
              Date of First Response: