Uploaded image for project: 'XWiki Rendering'
  1. XWiki Rendering
  2. XRENDERING-600

Faulty repeated insertion of 'class="wikiattachmentlink"' by WYSIWYG editing

    XMLWordPrintable

    Details

    • Tests:
      Integration
    • Difficulty:
      Unknown
    • Documentation:
      N/A
    • Documentation in Release Notes:
      N/A
    • Similar issues:

      Description

      If you create an "incorrect link" (it looks correct and it works !) to an attachment like:

      [[__title__>>attach:dok.pdf]]
      [[//title//>>attach:dok.pdf]]
      [[(% style="...." %)title>>attach:dok.pdf]]
      

      instead of

      __[[title>>attach:dok.pdf]]__
      //[[title>>attach:dok.pdf]]//
      (% style="...." %)[[title>>attach:dok.pdf]]
      

      the WYSIWYG editor will insert a term of (% class="wikiattachmentlink" %) every time you change your document and after several rounds it looks like:

      [[(% class="wikiattachmentlink wikiattachmentlink wikiattachmentlink wikiattachmentlink wikiattachmentlink wikiattachmentlink wikiattachmentlink wikiattachmentlink wikiattachmentlink wikiattachmentlink wikiattachmentlink wikiattachmentlink wikiattachmentlink wikiattachmentlink wikiattachmentlink wikiattachmentlink wikiattachmentlink wikiattachmentlink wikiattachmentlink wikiattachmentlink wikiattachmentlink wikiattachmentlink wikiattachmentlink wikiattachmentlink wikiattachmentlink wikiattachmentlink wikiattachmentlink" %)__title__>>attach:dok.pdf]]
      

        Attachments

          Activity

            People

            Assignee:
            surli Simon Urli
            Reporter:
            NorSch Norbert Schwarz
            Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:
              Date of First Response: