Uploaded image for project: 'Blog Application'
  1. Blog Application
  2. BLOG-74

User that had no rights on a blog (old blog) before changing to the new type of blog has many Red messages in the Blog now, also same issue appears when the user has Deny on a blog (Deny given with the new app to a blog already created)

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Critical
    • Resolution: Fixed
    • Affects Version/s: 9.4-milestone-1
    • Fix Version/s: 9.4
    • Labels:
      None
    • Environment:
      IE 11, XE 9.2
    • Similar issues:

      Description

      Preconditions: Before the switch to the new Blog type create a blog with some user restrictions. In my case I didn't give any rights to user U2 (See attachment)

      Steps to reproduce:

      1. Log in as the user with no rights to a old blog e.g. U2
      2. Click on Blog

      Expected results: The blog posts that the user doesn't have access to don't appear at all in the list.

      Actual results: Many red messages appear with "X is not a blog post!"

      NOTE: With the new blog app I logged as Admin and Changed the rights to another "old" blog. I've given DENY view to U2. Same issue as above happen in the Blog list.

        Attachments

          Activity

            People

            • Assignee:
              mouhb Mohamed Boussaa
              Reporter:
              ganechitoaei Gabriela Anechitoaei
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: