CKEditor Integration
  1. CKEditor Integration
  2. CKEDITOR-146

Some symbol are converted into HTML entities while saving

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Duplicate
    • Affects Version/s: 1.12
    • Fix Version/s: None
    • Labels:
      None
    • Similar issues:

      Description

      At least, the following symbols gets broken by the editor:

      ⇐ ⇑ ⇒ ⇓ ⇔ ¹ ² ³ ½ ¼ ¾ ‡ ∴ ¼ ¾ ½ Α Β Γ Δ Ε Ζ Η Θ Ι Κ Λ Μ Ν Ξ Ο Π Ρ Σ Τ Υ Φ Χ Ψ Ω

      which are represented by these entities:

      ⇐ ⇑ ⇒ ⇓ ⇔ ¹ ² ³ ½ ¼ ¾ ‡ ∴ ¼ ¾ ½ Α Β Γ Δ Ε Ζ Η Θ Ι Κ Λ Μ Ν Ξ Ο Π Ρ Σ Τ Υ Φ Χ Ψ Ω
      

      This might not be exhaustive, but just based on the attached screenshot test.

        Issue Links

          Activity

          Marius Dumitru Florea added a comment -

          Check the fix for CKEDITOR-38. Setting the "entities_*" configuration properties to false (from the Advanced Configuration text area) is probably a workaround.

          Denis Gervalle added a comment -

          From what I saw, there is only entities_greek as a boolean. We might also fiddle with the entities_additional parameter, but not sure if it has a default value that we should reset or just reduce.

          Marius Dumitru Florea added a comment -

          I would also try "entities" (boolean) and "entities_processNumerical" (boolean/string). Regarding "entities_additional" the documentation says

          Defaults to: '#39' (The single quote (') character)"
          

          but I don't think this configuration property is useful for you.

          Marius Dumitru Florea added a comment -

          I just checked and using

          config.entities = false;
          

          in the advanced configuration text area of CKEditor's administration section fixes the issue. See https://docs.ckeditor.com/ckeditor4/docs/#!/api/CKEDITOR.config-cfg-entities . I'm going to close this issue as duplicate of XCOMMONS-929 though.

          So in order to have this problem fixed you need to either:

          • upgrade your XWiki instance to version 8.4.6+, 9.9-rc-2+, 9.8.2+
          • or set config.entities = false in CKEditor's advanced configuration.

            People

            • Assignee:
              Marius Dumitru Florea
              Reporter:
              Denis Gervalle
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:
                Date of First Response: