Uploaded image for project: 'CKEditor Integration'
  1. CKEditor Integration
  2. CKEDITOR-333

CKEditor is not loaded when editing a page containing some macros

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Blocker
    • Resolution: Fixed
    • Affects Version/s: 1.40
    • Fix Version/s: 1.41
    • Component/s: None
    • Environment:
      Windows 10 Pro 64 bit, Edge 80, using a local instance XWiki 12.1 on PostgreSQL 12, Tomcat 9.0.27
    • Difficulty:
      Unknown
    • Similar issues:

      Description

      STEPS TO REPRODUCE

      1. Edit a page with CKEditor
      2. Click Insert > Other Macros
      3. Select 'Notifications Filter Preferences' macro or 'Pages' macro
      4. Click 'Submit' and Save the page
      5. Click 'Edit' to edit again the page with CKEditor

      EXPECTED RESULTS

      The page is displayed in CKEditor, in edit mode.

      ACTUAL RESULTS

      The CKEditor is not loaded, a box containing HTML is displayed instead.

      From all the macros, the issue seems to be reproducing with 'Notifications Filter Preferences' macro and 'Pages' macro.

      The issue could not be reproduced on XWiki 11.10.3.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                mflorea Marius Dumitru Florea
                Reporter:
                iandriuta Ilie Andriuta
              • Votes:
                0 Vote for this issue
                Watchers:
                4 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Date of First Response: