Uploaded image for project: 'Map Macro'
  1. Map Macro
  2. MAP-7

Don't load the maps in edit mode

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 1.2.1
    • Fix Version/s: 1.2.2
    • Labels:
    • Environment:
      XWiki 6.4 + Mozila Firefox 37
    • Similar issues:

      Description

      This prevents the macro from being inserted with the WYSIWYG editor on Firefox.

      STEPS TO REPRODUCE
      On a fresh instance of XWiki 6.4 and choose WYSIWYG as default editor from Preferences.

      1. Login with Admin credentials
      2. Go to Administer Wiki -> Add Extensions and search for "Map Macro" and install it.
      3. Create new page
      4. Click on MACRO button from WYSIWYG horizontal menu -> Insert Macro and search for "MAP".
      5. One result will be displayed. Click on it and then press "Select"
      6. Write a city & country in this format "Paris, France" on LOCATION field and then press "Insert Macro"
      7. A spinner is displayed and it's loading endless.
      8. Press Save & View and then a error is displayed on the bottom of the page "Error content: Exception while parsing HTML"

      This issue is reproducing only on FIREFOX 37.
      On Chrome & Internet Explorer it work fine.

        Attachments

        1. 1.png
          1.png
          87 kB
        2. 2.png
          2.png
          69 kB
        3. 3.png
          3.png
          71 kB

          Issue Links

            Activity

              People

              • Assignee:
                gabriela.smeria Gabriela Smeria
                Reporter:
                ady.manolache Adrian Manolache
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Date of First Response: