Details

    • Type: New Feature New Feature
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.1
    • Fix Version/s: 1.2
    • Labels:
      None
    • Similar issues:

      Description

      Allow to create tours that change the page when reaching a certain step.
      For example, we could start the tour in view mode and following the steps to reach the edit mode, when demonstrating the edit features. Or taking the user to Administration section, or another viewer of the page.

      1. create_stepsListing.png
        231 kB
      2. createTour.gif
        4.45 MB

        Issue Links

          Activity

          Pierre Bondoerffer added a comment -

          Fixed in https://github.com/xwiki-contrib/application-tour/pull/12 - it was already implemented but it didn't work for all use-cases.

          Vincent Massol added a comment - - edited

          Reopening since this caused the build to fail in 2 places

          Pierre Bondoerffer added a comment -

          Fixed the integration tests, sorry for the trouble!
          https://github.com/xwiki-contrib/application-tour/pull/13

          Ecaterina Moraru (Valica) added a comment -

          Hi Pierre Bondoerffer, the changes brought by this issue have not been documented in http://extensions.xwiki.org/xwiki/bin/view/Extension/Tour%20Application .
          We are missing the new "Target Action" and "Query String" fields. Would you have the time to add some details there?

          Ecaterina Moraru (Valica) added a comment -

          I really need some documentation or example, or maybe the feature is buggy or not working as expected.

          So I attached Tour.PageCreate.WebHome.xar. My purpose is to be on Sandbox.WebHome and help the user press on the "Create" button and go in the "create" action. This is not working as intended: it redirects to create and quickly after back to the view mode, finishing the tour. Is it something I am missing?

          Ecaterina Moraru (Valica) added a comment -

          ok - so managed some progress. "Target page" on steps are really start pages, you need to put them on the next step.

          Pierre Bondoerffer added a comment - - edited

          I have documented the changes just now, thanks! Basically:

          • Target page: where to go
          • Target action: what action to use (view, edit, etc.)
          • Query string: parameters to add to the query (editor=wiki)
          Ecaterina Moraru (Valica) added a comment - - edited

          So the current implementation is very limiting to what tours you can create.
          I've tried to create a tour for "Creating a page". The idea was that from the Main.WebHome, show the user the 'Create' button, display the options (title, templates), follow after clicking on the 'Create' button to the 'Edit' mode, when ask the user to add a Macro. Follow after 'Save & View'. Showcase the "History" tab and the Navigation Tree with the new page.
          See what I done until now in createTour.gif.
          Problems encountered so far:

          • TOUR-59: currently we can have only 1 tour per page. Ideally most of the tours should start on the Main.WebHome, since that's the wiki's Home. The current limitation ask that each tour has it's own starting page. That's why I created the tour on Sandbox.WebHome;
          • TOUR-57: we would need this Bootstrap Tour parameter in order to let the user click on the content menu "Create" button and continue the tour in the new location. Currently if he clicks on "Create" the tour ends, because the tour is not registered to the page. In the same page, you need this in order for the user to press on the "Drawer" so we can highlight the "Administration" link;
          • TOUR-62: on the Create step we would need to at least validate that the user entered a page title
          • TOUR-61: since the user entered a personalised page title we need to know what that is in order to continue the tour at that location

          I will continue to try to create a tour that uses more the view mode, but unfortunately "Creating a page" is a tour that is vital for the newcomers, that's why it was the first tour I tried to implement.

          You have Tour.PageCreate.WebHome.xar if you want to try the current "Creating a page" tour.


            People

            • Assignee:
              Pierre Bondoerffer
              Reporter:
              Ecaterina Moraru (Valica)
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:
                Date of First Response: