Uploaded image for project: '{RETIRED} XWiki Enterprise Manager'
  1. {RETIRED} XWiki Enterprise Manager
  2. XEM-134

Incorrect URL for XAR file in wikis created by XEM

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 1.6.2
    • Fix Version/s: 2.0
    • Labels:
      None
    • Similar issues:

      Description

      The URL for the XAR to import is incorrect for xwiki created in a farm. Say one has installed XEM 1.6.2 and created a wiki named 'testwiki.xwiki.example.com' the URL in "http://testwiki.xwiki.example.com:8080/xwiki/bin/import/XWiki/XWikiPreferences" points to:

      http://maven.xwiki.org/releases/com/xpn/xwiki/products/xwiki-enterprise-wiki/1.6.2/xwiki-enterprise-wiki-1.6.2.xar

      It should point to:

      http://maven.xwiki.org/releases/com/xpn/xwiki/products/xwiki-enterprise-wiki/1.8.2/xwiki-enterprise-wiki-1.8.2.xar

      Somehow the XWikiPreferences should detect whether the wiki is part of a farm and handle the "off-by-two" versioning of XEM, although i fail to see how it would be able to do so ...

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                tmortagne Thomas Mortagne
                Reporter:
                martijn Martijn Ras
              • Votes:
                0 Vote for this issue
                Watchers:
                0 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Date of First Response: